Download

Random: An Unreal Engine 4 Blueprints Remake of Shooter Game by Metahusk Cooperative

random-logo2.jpg

Project Moved - The project has been moved to a new thread!
https://forums.unrealengine.com/showthread.php?82661-Recruiting-Community-Project-Random-A-Blueprints-Only-Multiplayer-Game-by-Metahusk

Hello everyone,

We have been working hard to launch a creative development cooperative organized under a nonprofit structure at Metahusk.

Our first major project is http://randomthegame.com It’s a community directed blueprinted multiplayer game. The goal for our alpha is to rebuild parts of Shooter Game in blueprints. We hope the project will foster a collection of blueprints and assets that are useful to the community. This is why we chose to name the game Random. It’s an experiment in community directed gameplay. Everyone is welcome to help contribute. We have a system in place to manage how new content is submitted to the project.

We’ve spent a lot of time setting up a project management on a virtual private server. It has enough git space to store large projects. If anyone wants git space, forums, project management, or web hosting for free we are giving space away to those who have a somewhat developed project in the works. We’ve got about 200GB of space left. The hosts will handle heavy traffic. You’re welcome to do your own load tests.

As of February 2015 we have a working server browser system, teams, capture the flag system, spawning, friendly fire detection, and other things. I just upgraded to engine version 4.7 which caused some bugs with the team system and ready room spawning. I will fix the problems soon when I have time. I’m in school so that takes priority. (Also, the default character needs a lot of blueprints work. Much of it is experimental.)

Thanks a million to Rama and the VictoryPlugin and ufna for the VaRest plugin!

If anyone wants to help you’re more than welcome. (Just post in the forums.) We are excited to build our project into a collection of useful and free blueprints for the community!

Metahusk Creative Cooperative
Projects | Forums | Git | Nonprofit

Random: 100% Blueprints Multiplayer Game
Project Forums | Project Development | Project Git

70985120672b1dca5a1e9fcefaa45547eb22cd00.jpeg
server-list2.jpg
server-hosting2.jpg
teams-gun-model-aim-replication2.jpg
a58fd99142a2e112fad96a13aa2549a351302f15.jpeg
44474ff20dea86e2a7b57779ba91a8c44207d8a7.jpeg

Woooow Great Job
Great Project
im newbie so i cant help so much . but thanks for sharing this helpfull project

i did every thing
and clone it from github
this error message http://s10.postimg.org/acxr35v6x/sssas.png
i used 4.7.2

This is really awesome, can I make a request? Can you add a functioning scope with zoom for a sniper rifle that works in 3rd person as well?

In the readme it says:

  1. Navigate to \Random\Plugins and extract the files in VictoryPlugin.zip to the plugins directory into a folder called VictoryPlugin
    > Plugins Directory Structure: \Random\Plugins\VictoryPlugin"plugin files"

  2. Navigate to \Random\Plugins and extract the files in VaRest.zip to the plugins directory into a folder called VaRest
    > Plugins Directory Structure: \Random\Plugins\VaRest"plugin files"

  3. Execute Random.uproject and click Yes to Recompile Project Modules.

  4. Enjoy :slight_smile:

But i have a different problem, when using your API and APP id it seems to work with listing serveres in the browser. But when I replace them with my own, I can’t get it to show any servers on the browser screen…

Changed the keys in BP_GamestateDefaults and BP_BrowseMenu with my Application ID and REST API Key. On parse I can see the server information are received and listed on the website, but not in the game server browser.

Am I using the wrong keys or do I need to setup something on parse.com?

Edit:

Also spamming the refresh button will result in crash:

Error Infinite Loop detected in BP_BrowseMenu , asserted during OnClicked (Button_Refresh) with the following Call Stack

@Xenosis do u use 4.7.2 ??
because VaRest plugin need to rebuild look at pic http://s10.postimg.org/acxr35v6x/sssas.png
can i contact u to help me?

Yes I am using 4.7.2 and i did say yes to to rebuild them, but I did only get one missing VaRest plugin:

compile.jpg

Sure you can contact me, if you need any help…

now i moved the plugins to the engine plugins directory
and that Varest rebuild is out
i got this message http://s22.postimg.org/6sj5dpim9/asdadasdadasd.png
when i press yes i got this http://s14.postimg.org/49gyt6dch/error_try_rebuild_from.png

Sorry for my slow response. I’m checking out 4.7.2 right now to make sure it works.

I’m glad you liked it! I’m plan on doing the rifle things next. I’ve been mostly focusing on a game menu and server browser right now. There are quite a few bugs from moving to > 4.6 with the gameplay elements that I need to fix.

Thanks for the bug report. I will look into the spamming of the refresh button.

As far as parse.com goes, yeah, you need to sign up with an account and use your AppID and APIkey but it sounds like you did that already. The variables need to be entered in two different blueprints. You’re welcome to use my parse.com keys for now as long as you won’t pass 30 requests per second. I plan on launching my own system instead of using parse in the future.

I need to expand the tutorial on parse.com.

You need to add two custom classes at parse.com.

The first one should be called servers. In this class then add custom string columns labeled ip_address, server_name, map_name, game_type, player_count, player_max, and server_location.

The second custom class should be called timefetch. Timefetch doesn’t need any columns. It is only used to fetch the servers time.

895b7504ed5016658fb8e54d0868e2337d6695d8.jpeg

Do you have Visual Studio Express 2013 installed? I just downloaded the files from the git repository and recompiled in 4.7.2 without issues. My guess is that there’s a problem with the compile process on your system?

@MuhammadMadi

I’m uploading the plugin files right now. The download should be available in 10 minutes or so. You should be able to compile the project but maybe this will help you until you can figure out what’s going on with your setup. I’ve had some weird issues in the past. I had to reinstall Visual Studio once but that was many engine versions ago. Hopefully this helps you.

http://downloads.metahusk.com/random/03-06-15/

Download Plugins.zip

It looks like Parse.com is creating the classes and strings by it self when creating the first server…

But did try to create the classes and strings manually, but still no servers showing in the game browser and parse do get the information:

a1c43d6de88fc5a8fb42552d41d2ced63ea091f1.jpeg

Don’t understand why it wont work, Only changed the APP id and API key inside the blueprint and widget…

Are you using REST API Key as API key? Must be something wrong with my App id and API key…

it works now
My report
I uninstalled the visual studio community and UE4.7.2
and installed visual studio express 2013 And UE4.7.2 and it work fine now

I’m glad to hear you got it working. I will keep that in mind. I wonder why that version didn’t work…

@xenosis
Hmm, that is strange. I plan on launching a replacement to parse.com on my VPS but I haven’t had the time yet. I’m not a parse.com expert. Did metahusk’s parse.com id and key work? Yes, I used the Application ID and Rest API Key. I will PM you our metahusk account’s credentials you can try them.

Also, the VaRest plugin has a bug with HTTP requests on Android. A user submitted a fix but I’m waiting for the next release from ufna to include it. Much thanks to his hard work!

Also, just so you guys know there is a major bug with tracking what team a player is on. It broke with 4.6 version. I haven’t fixed it yet. I need to research a better method for tracking players in a unique manner. I was tracking this using the player controller but I’m not quite sure what the problem is now. I’m going to look into steam id stuff when I have the time.

if i join someone,i get dark level,why is that ?