Download

Ran into pretty serious problem with materials on complex skeletal mesh from Blender to Unreal ...

Hi everyone,

So I am trying to import a pretty complex skeletal mesh into Unreal 4 from Blender.
The good news is that the skeleton and animations work like a dream.
The bad news is that I can get my materials to fill the right meshes on it.
So I have around 230 individual meshes that are not joined inside Blender but they are all parented to the same armature.
I select all the object in Blender and export them as one single .fbx.
Then I import that .fbx into Unreal and I can actually do section selections inside the skel mesh editor window.
So its all there and if I import animations they work fine.
Now … the materials are the problem.

What DOES WORK:

If I use only one UV channel on each object and I select only 3 or 4 of them + armature.
If I bring that in as described above then the materials fill the right objects as they should.
No issues.
If I import each object one by one then all the materials work as they should.

What DOES NOT WORK:

If I select the entire plane model with all 230 objects.
That is when Unreal seems to get confused as to where what material should go.

I tried both import materials and don’t import materials. Neither works.
If I join all the objects then I get white meshes inside the editor window after lighting build and before build.

So … my only option here so far is to bring each object in one by one and then attach them to each other in BP.
I really don’t want to go through this whole workout.

Can anyone tell me what I am doing wrong?
Are there simply too many objects and Unreal is getting confused / threshold issues?

Everything is named correctly I checked. I don’t have UV channels with same names and objects don’t have same names.

I am working in Unreal 4.20.2 and its Blender 2.79b.
I tried both assigning material to material slots in skel mesh editor window and just sliding them onto object in viewer. Same problem.

TY

Should I create an animation BP for the plane and then do a SetMasterPoseComponet?
I should probably try that.

So it looks like my sections are getting mixed up.

So it looks like its a “section” issue.
Unreal thinks two meshes are joined and forms one section but they are not.
So how do I fix what mesh is what section? :slight_smile:
Is there a section editor?

Problem solved.
Name all the meshes’ UV channels the same. (If you use different names you get white meshes in Unreal)
Then I joined all meshes first in Blender before export.
Problem solved :slight_smile:

Materials now coming in nicely. colorsright.jpg