PSA Velocity stopping additional rotation?

Hey everyone, quick question. I have a flipbook particle in an emitter that I want to have following its velocity, so i set Screen Alignment to PSA Velocity. While my particle is now velocity aligned, it is now sideways because my flipbook had all the images facing the ‘left’ of the texture, rather than the top. All i want to do now is rotate the particle 90 degrees in relation to the camera, but the none of the rotation nodes are having any effect on the particles now. How do i fix this?

rotate the sprites in your flipbook. should be fairly quick to do with slices and a couple of photoshop actions. if you have the option and it doesn’t take insane amounts of time it’s always best to solve problems at the root instead of applying fixes down the road.

As above, change rotation of the image. Particle rotation won’t have any effect, because that’s exactly what the alignment system does, it rotates everything to face the direction of velocity.