(project name) could not be compiled

Hi,

We’ve encountered a problem, which seems to be about a corrupt project file. What happened was:

  1. we had a working blue print project based on the ‘Flying’ template. Everything was working fine and we worked on it for about a week.
  2. I tried to create a C++ class (empty standard class), but the process didn’t finish successfully, because I didn’t have Microsoft SDK8.1 installed. I did install that afterwards, however…
  3. Now I cannot open the project file anymore, because I get the following message: ‘The following modules are missing or built with a different engine version: UE4Editor-(projectname).dll Would you like to rebuild them now?’ After clicking yes, I get '(projectname) could not be compiled. Try rebuilding from source manually.

After messing around a bit, we managed to get it working and the solution was to open the Project file (.uproject) and delete everything between brackets in the “modules” section. The corrected file looks like this:

{
“FileVersion”: 3,
“EngineAssociation”: “4.10”,
“Category”: “”,
“Description”: “”,
“Modules”: []
}

I do have a question though: are there any known issues in windows 10 in regards to this functionality? (adding custom c++ class?)

Thanks!
Mitja

Hello,

  • If you create a new project and attempt to add C++ code to it, are you seeing the same error when you open the project file?

No. the problem happened because the process of incorporating a C++ class didn’t finish correctly.

We got it all working now. It turned out there was something wrong with our Visual Studio 2015 installation. Once I ran repair on VS2015 my Unreal Engine installation disappeared from Unreal Launcher. I had to install the latest version from scratch (v4.10.3) and then it started working.

Thanks,
Mitja