Project is normal on Vive, glitchy on Quest

(4.23.0 final, not preview)

Update: There seems to be two issues here: one issue with the blueprint code from the video where ArmSwinger just doesn’t seem to work at all on Oculus Quest for some reason, and another where standing too far from the origin on Quest results in these strange glitches pictured below.


On PC with a Vive, my project looks like the VR template. I created an empty C++ project, used the Migrate function to bring over the BP VR Template map and blueprints over, then went through [this tutorial][1]. All the way through, it looks fine, as expected, just like the video. On Quest, however, if I package and deploy the app at any point before starting the tutorial, it looks and performs as expected. But when I go through the tutorial, I end up with this:

As you can see, there are weird green artifacts, and the materials on the hands look black, red, and glitchy. Also, the input doesn’t function as configured, at all.

Edit: I noticed that the tutorial neglects to port over the code that sets the floor as the tracking origin. It’s kinda weird that this doesn’t cause a problem, but I guess UE4/SteamVR auto-accounts for it in a way that OculusVR doesn’t. Porting the blueprint functions fixed most of my problems. Now, I still need to figure out why the inputs I configured don’t seem to be working.

Edit 2: Standing far enough away from the center of the play space, towards the rear edge of the guardian, triggers the bug on app start again, even with the “fix” implemented. I’m starting to suspect a problem with the engine here, as I was able to reproduce this bug even in the default VRTemplate project, without the attempt at the ArmSwinger plugin. I’ll update the text at the top of the bug.

The VR template has some unique (not compatible with mobile VR?) .ini settings -

Try changing “r.Mobile.UseHWsRGBEncoding=True” to False in DefaultEngine.ini

Thanks for the response, Alex, but changing that setting didn’t fix it. I was still able to reproduce the issue. However, over the course of testing, I realized that the only way I could reproduce it was by standing towards, say, the northernmost end of the guardian area, holding the system button on the right hand to reset the “local center” to that area, then walking back to the southernmost end before starting the app. If the center was the actual center of the guardian, then I couldn’t trigger the bug.

I think it has something to do with that difference between the HMD’s location and where the player actually spawns. It may involve the Set Tracking Origin function somehow, as well.

Any further progress? I have the same issue here: weird messed up meshes only in VR - XR Development - Unreal Engine Forums
Changing the above setting did nothing other than make the level darker. I also just took the VR Template and modified it a bit. I’ve tried all the suggested solutions I can find.