Download

Project file not found : ../../../first_person/first_person.uproject for standalone project

I get the following error message in the console when I try to launch a first_person sample project, that has been packaged as a standalone project. I tried copying the first_person.uproject to the first_person/LinuxNoEditor folder and running the first_person.sh script, but I still get the same error message. The standalone game launches file however.

This is the command that I used to build the standalone project:



RunUAT.sh BuildCookRun -project=/project/software/tutorial/unrealengine/first_person/first_person.uproject -noP4 -clientconfig=Shipping -serverconfig=Shipping -nocompile -nocompileeditor -installed -ue4exe=UE4Editor -utf8output -platform=Linux -targetplatform=Linux -build -cook -map=StarterMap+Minimal_Default+Advanced_Lighting+FirstPersonExampleMap -unversionedcookedcontent -pak -compressed -stage -deploy -cmdline= -Messaging -addcmdline=-SessionId=1A2CCED508D7078EAE4BD48EBABCB236 -SessionOwner='developer' -SessionName='first_person_linux'


It would appear that the first_person.uproject file is not copied to the Saved/StagedBuilds/LinuxNoEditor/first_person folder. I guess this is a bug in some build/generate component invoked by the RunUAT.sh command. This is for the current UE4.22.3 release.