Project fails to build on 4.18.3 - -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command

I have a project that’s built using 4.16.3. I tried to build the project on 4.18.3 today, and got a bunch of errors, the reason of which I fail to understand. One such error is :

H:\GitHub\PaintGame 4.18\PaintGame.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.

I’ve never encountered anything of this sort before, and I have tried looking around but nothing seems to help. Any help or a nudge in the right direction is greatly appreciated.


Maybe you should see in the log file what was the problem during your packaging.

Anyway, here’s some solutions i have that solved few packaging problem, check if one of them help you:

  • see if you don’t have multiple instances of your project running
  • check the length of the path of some assets
  • check if all your blueprint compile correctly
  • if you are using c++, check if all your code compile correctly

I hope it will help you, without your log file it is not so easy. If you still can’t package your project, please provide your log file

Thanks for the reply Rayster. Unfortunately, I’m still stuck though. I had closed UE completely before starting the process on 4.18, and the BPs and C++ Code compiles just fine on 4.16.3, so I presume that shouldn’t be an issue ?
I followed your suggestion of checking the path length, but I’m still at the same place I started.
Here’s my log file

Thanks for your time and all the help.

Hi, sorry for the late answer.

Did you try to replace all your

#include "Kismet/HeadMountedDisplayFunctionLibrary.h"


#include "HeadMountedDisplayFunctionLibrary.h"


Otherwise I do not really see what’s going on with your issue

In my case, the error was due to an erroneous Blueprint function return type declaration:
UFUNCTION(BlueprintCallable, Category = Sound)
static unsigned int playSound(…)

Instead of unsigned int, I had to use uint8 for instance to make UE happy.

Obviously, the error message did not help find this one.
The actual error can be found in the VS output tab instead of the error list.