Download

Procedural Mesh with Emissive Material: How to prevent casting light into world?

I am creating a procedural mesh in code (UProceduralMeshComponent) and applying an emissive material to it, but I don’t want the mesh to cast the emissive light into the world to light other objects. Normally with static meshes, you can achieve this by turning off “Use Emissive for Static Lighting” in the Lightmass settings. Is there an equivalent method for doing this for procedural meshes?

That option shouldn’t be on by default. Also, it only works for static objects with built lighting so if you’re doing something at runtime it can’t use that feature anyway.