Download

Problems lighting a simple box correctly

Hey guys,
I have a problem with ligthing a single box correctly. I am just beginner, but what I understood from many tutorials is, that if I leave enough space between the uvs, choose the correct LM resolution and put everything on the grid there should be no bleeding. Of course there are many other important things, but in this case this should be everything. Or did I do wrong?

To understand my problem I added some images.0edcc64aead87b463a7a9ebe0c98621a5c777249.jpeg0e233bf0802fe1c85aea9d33378eabb1392b5d13.jpegb607d8798f122ba991f0c856f60fd9f1152a6802.jpege127f1ef1b2e0c77ec11c718708fd9ac3700414e.jpeg9051f2c754509e7b6e7d8c2ac8f5dbebe3dec06d.jpeg

2829c7b3c6eb3df9e4a3174048e16bb6b2f09b9f.jpegf505760edab3aaef195127a1cb233b566f0e4db9.jpeg

Lightmap Channel Index is correct

Grid Lines every 0.0156 (1/64 ->0.015625 -> 0.0156) in Maya

Everything on the grid. I even tried out another “solution” with more space in between, but still not working correctly

The Lightmap Density looks strange, like everything is messed up, but I dont know how much this view represents the lightmap

Grateful for every help
Josycopter

Several things might be the case:

1 - Lightmass is buiding AO seperately, and packing that into your lightmaps. In which case, you should probably tell it to stop. See if “Use Ambient Occlusion” is checked under Lightmass in the World Settings.
2 - Lightmass builds normals into your lightmaps. This would be the case if your normals were incorrect, or if there was any bleeding.
3 - Lightmass does not like building on objects with sharp normals. The default cube in UE3 had sharp normals, though.
4 - Lightmass is dumb.

I think the most likely answer is, Lightmass is dumb. It’s really not intended to be a perfect quality solution, it just takes care of indirect lighting. If you make it start taking care of more than it can, then you need to bump up the resolution to compensate. As for why the texture does not line up properly in the visualizer, I remembered reading from the docs that lightmaps are automatically padded to prevent bleeding at the edges of the texture. I’m not sure if the discrepancy you’re seeing in the visualizer is due to that, though.

Hey mariomguy,
thanks for your advice.

  1. AO was already turned off
  2. Normals are new to me, I compared them with those of the Starter Content “Architecture”, were I saw no difference so they should be fine.
  3. Yes, the architecture starter content had also sharp normals and showed also artifacts. One had way stronger artifacts than mine. :confused:
  4. Guess you are right

In just indirect light (not hit by directional and skylight) it showed less artifacts. It is really sad that there is no perfect solution, not even for a simple box. As far as I know Autodesk has a lightmass alternative for udk called “Beast”. There will be a 2015 version, really sure it will also work in UE4 so lets see how good this software will do its job.

“I remembered reading from the docs that lightmaps are automatically padded to prevent bleeding at the edges of the texture.” Can you tell me what that means and if I can change that?

What mariomguy means is that in between each lightmap (because multiple are atlassed together), Unreal adds spacing to prevent lightmap bleeding between multiple objects. That shouldn’t be your problem, but it got me thinking. From your Maya UV image, it looks like your UVs aren’t perfectly snapped to the outside grid line at the top and to the right. Is that just a product of a zoomed-out screenshot? Either way, that shouldn’t be the issue here, but it’s worth looking at since you’re having problems.

Also, what are your lightmass settings? Setting your indirect bounces to 4 or more and setting your indirect lighting quality to higher than one can help lightmass resolve its own problems (at the cost of build times), even though it will never be perfect. Heck, try increasing your lightmap size and forget about remapping the UVs. If one pixel on your 64px map gets blurred or messed up, it can smear pretty far with filtering.
If you’ve still got problems, trying importing that cube into an example scene like the Architecture one to see if there is a difference.