Problem getting authorized to see UnrealEngine repository within Epic's GitHub

Sorry to say this, but documentation is pretty messy even for how one should get access to UE4’s source code.

Let’s see.

A) In the tutorial (https://docs.unrealengine.com/latest...ine/index.html) it is said that “For instructions on associating your GitHub account with your Unreal Engine account, visit the UE4 on GitHub page”.

B) Fine. At that page, one is told that the steps to do that are simply the following:

step 1
Create an account at GitHub.com

step 2
Go to your account and associate your GitHub username by entering it into the GitHub account field.

Step 3
Get started by going to our GitHub page and downloading the full source.

I already have a GitHub account that I have been using or years, so that’s done. Due to the confusing wording, I assume step 2 only means I have to log into my GitHub account, because what could mean to “associate your GitHub username by entering it into the GitHub account field”?

C) Done that, I go to Epic Games · GitHub. However, UnrealEngine repository does not appeart to me. Only a “Signup” one, described as “Information about signing up for a free Epic Games account”.

D) When I click that, it opens a README.MD file containing the following information:

“Unreal Engine is now free!
To access our repositories, sign up for a free account at UnrealEngine.com and register your GitHub ID using these instructions.
After that, you can find our repositories here:
Unreal Engine
Unreal Tournament
(Note that you must be signed into GitHub for these links to work.)”

Well, I am already signed into my GitHub account. But when I click the “Unreal Engine” link, I am sent to a 404 error page saying “this is not the web page you are looking for”.

For a second I think “well, it might be because of that account association thing, that here in this README.MD file is being called ‘register your GitHub ID’”. Then, I decide to click in the “these instructions” link that is contained within that README.MD file.

E) Surprise: I am sent back to the item B) above, in a circle that never ends.

So what I ask is for some charitable soul to point me in the right direction here. I have a GitHub account. I obviously have a UE4 account. When I go to EpicGames GitHub page (properly logged into my GitHub account), there is no accessible Unreal Engine repository. What else do I have to do to get access to Unreal source code?

Thanks in advance for your time.

1/ Go to unrealengine.com and in the top right hand corner, click on Account/Personal

2/ Click on the second tab “Profile”

3/ Look for the entry that says “Github Account Name” and enter your github account name there

4/ Click Save

5/ Wait for an email saying that you have been invited to the Epic github repo.

Many thanks for your reply.

First thing to say is that such steps should be described any where in the documentation. But said that, I had already tried it with no avail.

One thing that I have noticed is that my GitHub login name, which mixes lower and upper case letters, is automatically transformed into a all-lower case word in the UE4 profile settings. I will play around with that, to double check if that is something that might be giving me problems.

My github username also has lower and upper case, can’t remember what happened when I entered it, but obviously it must of worked since I am linked to the Epic github repo. You might just need to wait a bit for the email to come through. I know a friend of mine had some issues, but that was because he was not patient, and kept updating the github username section, which resulted in him getting a lot of emails saying he had joined, quit, joined, quit, joined, etc.