Download

Potential Bloom Performance Bug On Certain Resolutions

Ok, so I’ve been having this bug for several engine versions now (currently on 4.25) where the “expensive” Bloom option (FFT) has a drastic falloff in performance at certain resolutions. We are talking of going from a cost of a few ms a frame to over 500 ms a frame just by nudging resolution barely past 4k. It’s like Bloom rendering hits a wall, or something. Even on a blank scene. Just enable Convolution Bloom and set the resolution to 4k, then set it to 5120x2160 (or some other resolution above 4k). You should see a giant hole in performance.

Anyways, the easy solution is to just disable the expensive bloom on resolutions over 4k, not a big deal. As I’ve said, this is how I’ve dealt with this bug for the past few engine versions. I detect if the pixel count exceeds 8.8 million pixels (4k) and then disable the expensive bloom.

Well, a few days ago my Odyssey G9 monitor arrived. It’s an ultrawide. To my surprise, the bloom “performance wall bug” reared it’s head, even though I was at a much lower resolution on this monitor (5120x1440 which is almost 1.5 million pixels less than 4k). In my testing, screen sizes exceeding ~5.8 million pixels (right in between 1440p and 4k) is where the performance wall is hit with THIS monitor.

Now, I’m worried that screen shape can affect at what point this “bug” is triggered, which is something I don’t account for. I figured pixel count alone caused this issue.

Anyways, I wanted to post this to see if anyone else has had this issue and if any solutions exist. 4k gaming is pretty standard nowadays, so kinda surprised I couldn’t find anything about this on the forums.

Thanks,
Blake