Download

Postprocess volume doesn't work in exe

Hi everyone,
I have some weird strugle with postprocess volume.
Dof works in the editor, same with preview, but when i play compiled exe, then dof seems to dissapear (like it wasn’t there from start).

I’m working with 4.18 version of ue4, its VR project. (HTC device)

Ive tried to force Epic settings, but it doesn’t work.
Even if i define values by blueprint, still the same.

Are you using a project based on the VR template? If so, it comes with two post process volumes and some blueprint logic that forces one to be enabled in non-VR and the other for VR.

Oh i dont remember now, can you tell me where i need to look? Its some kind of global blueprint?

It’s in the level blueprint. There should also be another postprocess volume in the level.

Oh that way, then no… there is no another postprocess than what iv added.

Okay i’ve found the solution… just need to create node with r.DepthOfFieldQuality 3 command for each level, and now everything’s fine.
Anyway, thank you for your answer. : )