Download

Poor shading on Datasmith imported CAD objects

Has anyone else (who don’t bake light) encountered this?

I filed a bug report on it, but the reply was basically that this is normal and due to real-time lighting, and it is, because if I turn my directional shadows off, it goes away:

But in a product viewer, you need to keep stuff realtime, because you switch out stuff and move stuff around (and of course, in VR, you can’t use RTX shadows or AO).

Anyone got any tips on how to mitigate this? The bias settings didn’t really do much…

giving this post a bump, since it experienced the forum bug where it gets placed at the very end of the section.

import the model in 3ds max and then give it a smooth shading using edit poly and then export it and import it in unreal engine.

That, unfortunately, does not matter in this case, since as you can see from my second screenshot, it’s already smooth.

The artifacts seem to be a result that’s entirely made from the dynamic shadow map system in Unreal.