[Plugin] Web UI framework plugin (VaQuoleUI)

HUD for GameMode (http://i.imgur.com/rfduv9w.png)

Resize webview

Just Texture Simple node translated in Param2D

Thanks, ga2mer. I’ve finally managed to get it working :slight_smile:

Get well soon!

I would love to use this plugin for my HUD, it seems awesome

Okay sorted it finally, and got it to work was miss-understanding the install instructions combined with different engine version. compiling the latest source and copying the required files across to the engine folder solved things for me.

Where did my post go? I was asking about any examples how to setup the gui from code. Thanks

Just check the HUD source inside the plugin :slight_smile:

What can I do to get this to be compatible with 4.2.0?
I have extracted the files to their appropriate locations in my project folder but when I run my project it says it is either not compatible or needs to be recompiled… etc.
…it did not compile.

I’ll make a huge update at the weekend. It will be pre-compiled for 4.2.1

Nice ufna!! looking forward to update.

I really love this plugin so far! thanks again

Great! This have so much potential. Good job ufna!

I am a unreal engine4 4.2 version developer.

I used coherent-UI before. until I found u program in github. I decide to give up coherent ui to choose VaQuoleUI.

but when I compiled my code. there are many problem for UE4 4.2 version.

it can not find the third party source following

#include “VaQuolePublicPCH.h”
#include “VaQuoleUILib.h”

can you tell me how to link the include with third party. and if it is possible can you give me some tutorials for how to develop a unreal4 plugin.

thanks very much.

Please check that you’ve applied right directory structure: http://gyazo.com/d3a8587f1b0e85d0825fda90eac9bacc

Hi ufna,

Thanks a lot for your work. I am very excited about this plugin, and I would really like to try it out. However, I have been unable to do it so far.

The “Installation” section says all one needs to do is just copy the binaries to the project folder and that’s about it. However, doing so does not work for UE4.2. So I tried to build my own binaries from source, including them in the engine source code and building the engine with them. So far so good (after commenting an include that is no longer needed). But then I run the project and it fails to load Qt5Core.dll, even though I have Qt installed in my machine. So I took all Qt DLLs along with “imageformats” and “platforms” folders from your binary distribution and copied them to my game’s binary folder. After this, UE4 editor launches just fine, I am able to enable the plugin and use some of its blueprints (“GetTexture”, for instance). However, when I run the game I get an error saying “this application failed to start because it could not find or load the qt platform plugin windows”.

I am not a Qt expert at all, but my guess is that the Qt binaries you included, particularly qwindows.dll, are somehow UE4.1 dependent and don’t work with UE4.2.

So my question is, what am I doing wrong? Why is the plugin not finding my machine’s Qt installation? How can I generate my own DLLs for my project?

Thanks a lot!

You should copy them not to your game’s binaries folder, but to add them to the engine’s binaries, and it should be okay.

It worked perfectly! Thanks again for your effort and your quick response.

ufna,

What platforms does this currently support?

can we expect a new 4.2.0 version this weekend?

PC, Mac, Linux other platforms are under development

Currently I’m fixing some race conditions between threads, and I think that update will be tonight or tomorrow morning.