Download

Playing an animation stops animation blueprint from generating events.

Hello. I’m trying to get started with the UE4 editor and am running into some pretty basic issues. I have a project where I have a character and an animation blueprint for her. The issue I’m having is when I play an animation from the character blueprint, the Event Blueprint Update Animation in the animation blueprint no longer fires. Send help please! I tried to illustrate the problem as simply as possible in the provided screenshot.

Edit:I think I found what I was looking for. There’s a node called Set Animation Mode which gives control back to the animation blueprint after a duration. This seems problematic though. I did some searching and found a node called Get Segment Length, but that doesn’t seem to be a property of an “Animation Asset Object Reference” so it looks like these numbers have to be hard-coded. I’ve looked into the way that the Paragon Shinbi character’s animation blueprint and character blueprint is setup. They use Play Anim Montage with nothing screwy added. I’ve tried to emulate this, but when I call Play Anim Montage on a Montage containing the same animation that I managed to setup after using Set Animation Mode -> Use Animation Blueprint, nothing is playing visually. Oddly, I can still retrieve Anim Notifies from these montages though, despite nothing being displayed. Any advice would be greatly appreciated. Thanks.

Another Edit. I ended up solving the problem by creating another animation slot and setting up a layered blend per bone with my exiting animations. This seems very weird to me and I would appreciate feedback on whether this is a normal/correct thing to do.I am however able to play my animation montage through the screenshot setup by assigning them to the TestSlot slot.