Physics substepping not working right

I have a lot of problems with physics, like bones going through collisions and bones going all jittery.

Now it appears physics substepping was always activated in UE3 while it is not in UE4, that is why physics worked so much better in UE3. But when activating it in UE4 it introduces lots of new issues. Like releasing a physics handle component will not let the object fall and all blueprint related physics settings being much slower. Like add force moves everything like it is in slow motion.

Is substepping really still experimental in UE4? And why is that such big step back from UE3 physics in the first place? Is there any date where substepping can be expected being not experimental anymore?

This is all pretty frustrating coming from UE3 and finding the UE4 physics being so problematic.

I tried it now in the latest 4.11 preview and substepping worked there without those substepping issues I wrote here. The note that it is experimental and things can brake is still mentioned there though.