Download

Physic simulation toggle stops floor from colliding with objects

I am getting crazy trying to figure out what’s happening.
I have loaded the starter map project.

I do the following:

First:

  • move one sphere above one platform and then up
  • activate “simulate physics” on the sphere
  • hit play…

Result: the sphere falls on the ground and stops.
That’s right

Second:

  • activate “simulate physics” on the platform
  • hit play

Result: the sphere and the platform both falls
That’s OK

Third:

  • deactivate “simulate physics” on the platform
  • hit play

Result: the ball passes across the floor without any collision
That’s not right!!!

I have checked one by one all the options (collision and physics) and they are alle the same before and after.
But before the ground stops the ball and after the ground is not colliding at all.

The question is: is this a bug or it’s my fault?
How to fix this?

I run 4.5 version of ue4 but the problem still exists in the 4.4.3

See all the attachments
Thank you all!

Hi Asdraban,

Thank you for reporting this. I have been able to reproduce this and this is in-fact a bug to which I have submitted a report (TTP: 349621).

What’s happening here is that the floor is not using a collision primitive and instead using “Complex as Simple Collision” that is causing the issue.

As a workaround you can open the mesh in the mesh viewer and go to “Collision” in the Menu bar > Add Box Simplified Collision.

In the details panel under the tab “Static Mesh Settings” > Collision Complexity > Change this to Default.

This will fix that for you.

Tim