Download

Particles in VR - they move with the HMD

I’m using a GPU sprite emitter to create the effect of a floating dust field in space.
There is a terrain which stays locked to world space when I look around in the VR preview, but the particles move with the headset - not locked to the headset but they parallax with it slightly and don’t feel like they’re locked to the terrain.
I have tried changing the Screen Alignment of the particles to all options and none have fixed this issue (though ideally I want them as ‘PSA Facing Camera’)

Does anyone know how to get a particle system to stay locked to world space co-ordinates when in the VR preview? (they look fine when using the mouse to look around in a standard viewport)

Thanks

This happens when the camera attached to the character has ‘Use Pawn Control Rotation’ checked (under Camera Settings)
When checked the HMD still works but it seems the center of rotation is off - almost like the character’s heads pivot is set back from the camera’s rendering plane.
Unchecking that value has fixed my problem - just in case anyone else has the same issue.

This happens to me even with ‘Use Pawn Control Rotation’ unchecked. It doesn’t happen when I have PSA set to ‘Facing Camera Position’, but then my particles are limited to being square. Is there any way around that?

It used to work fine in 4.11 / 4.12 :frowning:

Did you file a bug report with video showing the issue ?

Probably the same as the thing I found and reported for all android HMDs (gearvr and daydream)?: [Android] Particle emitter moving with up and down camera movement - UE4 AnswerHub

Would be great if you guys could upvote the issues ticket to have it fixed!:Unreal Engine Issues and Bug Tracker (UE-39357)
:slight_smile:

Upvoted. Have you tested in 4.12 just to see if it was working? (Might help Epic discovering the issue)