Particles + DoF in foreground issues (Yes, I disabled Render After DoF)

Hey folks.
As you can see in the screenshot here, my particles aren’t rendering with DoF when they are in front of another static mesh. They DoF fine in the BG, but as soon as a particle moves in front of another mesh, it is not DoF’d out. Yes I have disabled Render After Dof in the material. The material is translucent. Everything looks great when the material is set to opaque or masked.

Thank you!