Download

Particle system source point lagging behind when moving attached component.

Hello,

I am trying to implement a laser beam (a particle system) coming out of a laser sight in my project. The laser sight is attached to a weapon Actor.

In fact, I do not set the beam source point as it set in the particle system to be “Emitter” which attaches it automatically, I simply update the beam’s end point every tick.

When moving the gun, in first person, the laser is lagging behind for like a frame. The source and endpoint (I believe the issue is the same). As this is a multiplayer game, I notice that from another players perspective the laser works perfectly, it doesn’t lag behind, so that only happens “client” side. So, I even tried setting the tick group from begin play as seen in other examples. No luck.

I have seen various suggestions to force the tick group be Post physics or higher for the components that the particle system is attached to, however, that is not working for me (see screenshots).

Am I setting the tick update in some way incorrectly, or does the tick update have to propagate up the whole attachment hierarchy? Even the weapon? I have also tried that, but didn’t work.