Particle SubUV material node UV input issue

Simply put, the UVs input of the Particle SubUV material node is ignored altogether.

As someone asked the same question in 2015, I can’t help but to ask it in the forum again if there is any solution already or attempt to fix it. I am using the the 4.20.3, supposedly the latest stable version. While I can achieve the same result with the FlipBook material node and Dynamic Parameter module, it nonetheless occupies 1 out of 4 precious Dynamic Params.