Particle distribution bug in Cascade?

I’m working with Cascade at the moment and have run into what I think is a bug of some kind. Basically any type of module (Initial color, Size over life, etc) can’t have its default distribution type changed. Whenever I change a distribution type (For example, Vector constant to Curve) my distribution type drop-down menu just says “None” and I get no options. Has anybody else experienced this?