Download

Paper2D blocking collision missing?

HI guys,

I am making 2D top down game and I have 2D background image in the scene. This automatically created a box collision around the floor, but this collision indicates walk-able areas only.
When I add a new box collision from the top bar, there is no way to set it as non-walkable collision? This should block everything in the scene, player included.

If I edit the floor collision, the player can walk on this area, but when he steps out of the edge he is falling into the infinite space like its a bridge. How Can I set it up to stop him fall from the collision edges?

Thanks!

assuming that the floor use the z axis for instance the object for place an object that block anything on it you need to set the z axys of the floor to 0 and set the z axis of any type of object included the character to 1, obwiusly in any object intended as non walkable surface you need to enable the correct option into its option panel. for stop the character at the end of a floor simlpy add a wall on each edge (if yo don’t want to see the wall in game simply set it invisible in game)