Download

Packaging to Android - App Won't Launch?

Hi there,

I’ve been creating test projects for deployment to a Samsung Galaxy S6 with the new Gear VR. About a week ago I had a successful test where everything worked great. I recently had my C drive replaced and had to reinstall all of my software. When I tried to package another test project, the app appeared on the phone but did nothing when I tried to launch it. I’ve tried troubleshooting, referencing the Gear VR UE4 Quick Start guide, but no luck. Any comments or guidance would be much appreciated.

Thanks

I just wanted to follow up as I found the solution to my particular issue. Hopefully it will be helpful to others. I was using the “Cardboard For Gear VR” app and forgot to switch it back to allow Gear VR apps to run. So if anyone is disabling the auto-launching of Oculus on an Android device with an app or with another method, you may need to re-enable it. If you have it enabled for Google Cardboard style apps, it may not allow your Unreal app to run.

As a first step I would check output from LogCat to see if anything obvious shows up. You can run from <android-sdk-folder>/tools/monitor to get LogCat going at least from NVPACK/OSX install I am using. Not sure where it ends up on Windows but probably somewhere similar.