Packaging Question.

hey guys, I package my ArcViz project to a ETC2 package. Everything works well but when I lauch it on my Android Note10… the light maps ar missing or extremely low res. Why does this happen? Also… if i touch the onscreen controls and move around… it crashes into a black screen. if there a android emulator you guys use to run the file on the PC rather than the phone?

lol! this driving me nuts. there must be something obviously wrong that im doing. I keep getting a black screen after the UE logo. But i figured out how to get it out from always going into the black screen. I uninstall the level from the phone using the uninstaller on the folder its build. RESTART. Then reinstall the level, RESTART. then launch and it works. But i keep getting the red messages in the screenshot and look at my lightmaps! its like they are all 32 resolution!

the last pic is how it looks on PC. Id like to add that im following the steps to package it from here.…ize/index.html

Also will add that i tried the same install on a sgs6 edge device. that one doesnt even go into the level.

Any tips from the vets?

heres some screen shot from my PC end. No ue4 errors reported when building. But always migrating this to Android… it just looks terrible.

Enable Mobile HDR in project settings (if you haven’t already), and instead of ETC2 try ASTC.
For more advanced post process stuff you need to open the DefaultEngine.ini file in your Config folder, and in the [/Script/Engine.RendererSettings] category you need to add

For general optimization tips check out this page Performance Guidelines for Mobile Devices | Unreal Engine Documentation

Thxs for the tips! But I think I solved it. Might have had way too much data in it. I am starting fresh and optimizing everything and its loading up fast and good now.

Ok… im bringing in everything again and I am half way importing and Android now says im over pool. What tips do you guys have to minimize the texture pool besides making the textures maller and compressed?

Im a bit confused . Does streamin pool mean the amount of textures or the amount of polygon count? Or both?

hmm… i seem to be stuck on “texture streaming pool over 23.234 mb budget” message inside my abdroid device. I have even dropped my polycount and texture sizes by 80% and still getting it. Any ideas?

maybe a better question is … Whats the polygon count limit for android? sorry… all new to this. my backroound is strictly 3dsmax with several render engines. i go the hang of Unreal for Archviz but migrating it to a Android seems to be a challenge.

Ok. Solved the issue. Just has far to many polygons. My arch Viz went from 3.9 million to 1.9 million. Optimized all textures aswell. And now it load extremely fast with no errors. Had to go over every model and to some i had to remodel with less polygons and other I just dropped down the meshsmooth orr turbosmooth a notch. but it worked.

ok… i might have been wrong on my assessment. Turned out the streaming pool issue on the mobile part was caused by have more that 1 box reflection actor. if i leave it at just 1… works fine.