Packaging Problems - Development, any ideas where the problem could be?

This problem ONLY shows up on the android device, in editor the levels load fine.

On the phone, levels will load fine when using the “launch” option but packaging creates problems.

Created a separate project using FP blueprint to test this out and I was able to package the levels and load from level to the next just fine.

This leads me to conclude that something is wrong with the way I’m packaging the levels for my project.

What I’ve tried so far:

  • Migrate the test levels from FP blueprint into my project : Now I’m getting the same problem with those levels so it’s probably not the levels themselves.

  • Move FP blueprint example to the same location as my project : FP blueprint still works the same, so it probably has nothing to do with where the directories are located.

  • Also note, my project is 118 MB, the FP blueprint test was 116 MB, so it’s not the size.

Did you check the Output log if the maps are being packaged?
Also, you can check the Build directory, subdirectory Android to see if the maps are included in the build.

This “issue” is a reoccurring thing so a search on the forum or answer hub should provide information on how to include the maps in your package builds.

I added
[AlwaysCookMaps]
+Map=/Game/FirstPersonBP/Maps/Level2complete
to DefaultEditor.txt file

after that the 2nd map name would show up in “CookerOpenOrder” file

but the 2nd map still doesn’t load
and the 1st map sometimes crashes before it even comes time for the 2nd map to load

both of these problems are only when I launch from the project launcher

Hi Death Strike,

Launch only pushes the current map to the device. Package will include all assets unless you specify maps to cook (any maps not added to [AlwaysCookMaps] will not be included).

Hi Chris, I’m using the project launcher which does the packaging too…unless I’m mistaken

UPDATE:

So it seems the issue is not the map, it’s the loading. I just did a test where instead of loading the next map, I tried to reload the current one and it crashed as usual.

Any update on this issue? I’m having the same exact issue.