Packaging error for Android 4.12 (ios works)

Hi, I’m running into an issue I can’t seem to find the solution to.
I keep getting this error trying to package an Android build (on 4.12), (ios build works perfectly fine):

BUILD FAILED
C:\NVPACK\android-sdk-windows\tools\ant\build.xml:888: The following error occurred while executing this line:
C:\NVPACK\android-sdk-windows\tools\ant\build.xml:890: The following error occurred while executing this line:
C:\NVPACK\android-sdk-windows\tools\ant\build.xml:902: The following error occurred while executing this line:
C:\NVPACK\android-sdk-windows\tools\ant\build.xml:283: null returned: 1

I’ve viewed several other posts with the same error, and none of those solutions have worked for me.
such as:

I’ve rechecked my environment vars multiple times, and installed all of tools for the correct platforms using the Android SDK manager.

I’m completely stuck right now, any help in tracking this issue down would be greatly appreciated!
(I’ve attached my full log file for viewing)

Hey Funkstatic,

Could I please see a screenshot of your Android SDK settings from within the editor? You can get to them by going to the Project Settings > Android SDK.

Thank you!

Thanks for the reply. (I’ve attached the screenshot below)
I’ve also messed around with the SDK API setting located there trying out a few things and haven’t had much luck.

Let me know if you have any suggestions, I’m quite stuck on this issue.
Thanks
[1]:

this is mine which works fine :slight_smile:

I just tried changing my SDK API to matchndk like yours and sadly I still error’d out with the same thing as I was seeing before

Funkstatic,

You need to upgrade your Android NDK to r11c, through CodeWorks not AndroidWorks. First you’ll need to uninstall Android Works. Once that’s complete, install CodeWorks and update the path for the Android NDK in the editor under Project Settings > Android SDK.

Please make sure you check your firewall and antivirus to make sure they’re not blocking the downloads due to a feature being switched on in the their settings.

Thanks!

Hi I completely uninstalled and re-installed like you suggested and it everything seems the same as it was. I believe my original installation was through CodeWorks, not AndroidWorks at least that is what my previous installation directories seem to show but I could be mistaken.

Anyway, the link you provided through codeworks only provides NDK r10e, not r11c .

Am I missing a step here or is the link incorrect?
Info from the download page:
“Release 1R4 adds full tools, libraries, samples support for the latest Android M (Marshmallow) release and includes the latest versions of Developer Tools (Tegra Graphics Debugger 2.2, Tegra System Profiler 2.5, Nsight Tegra 3.3, Visual Studio Edition, PerfKit 4.5), IncrediBuild 7.1 for Visual Studio, the latest Android NDK (r10e), SDK (24.4.1), Platform Tools (23.0.1), and Build Tools (23.0.2), CUDA, OpenCV and PhysX support, NVIDIA GameWorks OpenGL sample source code and device drivers.”

I can’t seem to find r11c anywhere on the nvidia site. :confused:
Apologies that this is such a headache, and thanks again for continuing to help me look for a solution.

Image of what I’m seeing installing from codeworks (r10)

Funkstatic,

Nvidia CodeWorks for Android link I provided above should take you to the correct location I see r11 being listed.

However, I’m going to start from the beginning to make sure you’ve gone through the steps the correct way, as it’s possible a step was missed and the error occurred.

CodeWorks is not compatible with any version of the engine prior to 4.12. You will need to uninstall AndroidWorks before installing CodeWorks.

  • Navigate to C:\NVPACK (or wherever you have your installation) and run the uninstaller located there.
  • Once there, hit next and wait for the Uninstaller to process the removal.
  • Once completed, this will ask you to restart. Restart your computer. When this is finished, feel free to remove leftover files in the NVPACK directory.
  • Once the old installation has been completed, obtain the installer for the new version.

Binary: [EngineInstallLocation]\Unreal Engine[EngineVersion]\Engine\Extras\Android

  • After that is set up and the Android NDK screen (as shown above) appears, choose standard and hit the next button to begin installation.

This should completely update your Android NDK like it needs to be for 4.12. Let me know if these steps are more helpful.

Thank you! :slight_smile:

Thanks for the new steps.

I was able to properly update myself to NDK r11, I re-checked all my environment variables and in editor settings and they’re all set as well.

However I’m still getting the exact same error on package.
I’ve attached a brand new log and a screenshot of my in editor path settings. (I tried setting my SDK level to ‘matchndk’ as well and it didn’t change things)

Please let me know what else I can try, and thanks again for all of your assistance.
[link text][1]

What are your Minimum SDK and Target SDK version set as in Project Settings > Android?

Sorry for the delayed response.
In Project Settings>Android I am set at the following:
min = 15
target = 22

I tried changing min to 19, and 22 as well, and both still gave me the same errors on package.

Any suggestions regarding this?

Do you have Support ARM64 chcecked off under Project Settings > Android > Build? If you do, uncheck it.

Please delete your Intermediate and Saved folder from your project and try to package again.

yes, Support ARM64 is set to OFF.

I tried deleting both of those folders and re-packaging and sadly I still get the same error.

Is there any other information I can provide that would be helpful to this? Please don’t hesitate to ask, I’ve been stuck on this for awhile now.

Are you using GooglePlay version 5.8 or a different version? Currently we only install version 5.8.

I actually have been building without it enabled for testing purposes.

I tried installing it and enabling it in the project settings, however it still error’d out in exactly the same way on package.
btw, I installed it via NVPACK SDK manager, and it installs version 7.8 as far as I can tell (there’s no option to choose what version.)

Should I manually figure out how to install version 5.8?

You can switch it back to 5.8 from the CodeWorks installer.

Sorry about the late follow up, but can you explain where in the installer you can switch the google play version?

I can’t seem to find it anywhere and I just went through another complete re-install to try to find it.

The only thing I’ve seen is in the SDK manager a single check box to install google play. Nothing about different versions available sadly.

Thanks

Install Google Repository/Android Repository from the SDK Manager and then go to BUILD\Engine\Build\Android\Java and edit aar-imports.txt. You’ll need to add new entries, change it and point it to the different version.

Admob requires 9.0.0, so if you set it lower, the ads won’t work. That is 4.13 specific though.

Good luck!