Packaged VR games are always fullscreen. How to launch windowed?

Hey there,

It seems like I’m having the opposite problem that a lot of people are having. I don’t want my packaged game to be fullscreen, but it launches like it regardless of the .ini configs I throw at it. ex: In my DefaultGameSettings.ini

[/Script/Engine.GameUserSettings]
 bUseVSync=False
 ResolutionSizeX=1280
 ResolutionSizeY=720
 LastUserConfirmedResolutionSizeX=1280
 LastUserConfirmedResolutionSizeY=720
 WindowPosX=-1
 WindowPosY=-1
 bUseDesktopResolutionForFullscreen=True
 FullscreenMode=2
 LastConfirmedFullscreenMode=2
 Version=5

It’s my understanding that FullscreenMode=2 should make it windowed, but it’s always fullscreen. When I start the packaged game, it looks like it starts in the correct resolution, but after about 0.5 seconds it switches to fullscreen. It’s almost as though as soon as the HMD kicks in, it goes to fullscreen. In comparison, if I package a non-VR game, then everything is windowed as expected.

My workaround right now is to run the fullscreen off console command on Begin Play. Not sure if that’s the best approach though.

Anyone else experiencing this?

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/settings that may be involved?

Hello ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,