Download

Packaged project Win 64 Not start at all

Hi all, I’ve builded the Shipping Win64 of my game, The problem is that when I try to execute the .exe file, nothing appear (no error, no Game).

I’ve Also Tried to executes it using -log options (Cubes.exe -log) The project name is Cubes, but nothing change and no log is showed or log file created.

I’ve try to build Win32 version but nothing changes…

I’ve try to do what said before also to exe that is located into binaries/Win64 folder.

I’ve Try this on another PC and this still not working.

This is not the first time I package the project but is the first time this happens.

Can you please help me to understand what i’m wrong?, because I don’t know what to do

Thanks in advance!

Logs aren’t created in shipping builds IIRC (at least they’re not for us). I would recommend building out the project WITH debug files included in Development or DebugGame configuration, and launching the packaged game from Visual Studio. You should then be able to see where the project is breaking.

Note that your build will fail unless you download the debugging symbols for the engine version you’re using. Make sure you have them by checking with the Epic Launcher.

Capture.JPG

I ran into some issues with a build i made too. Not sure it’s related, but wanna pitch in with what issues i had.

Some users reported that antivirus caught the exe file and it returned an error 5. After disabling antivirus it worked. How can we mark the file as safe?

Other issue i heard, was that c++ redistributables for vs2015 was missing. Is there a way to get that installed automatically if it’s needed?

Lastly but this is probably an edge case. One user specifically had an issue where it said: Asserton failed: CurrentShadingPath <EShadingPath::Num [File:d\Build++ue4+release-4.14+compile\sync\engine\source\runtime\renderer\private\PostProcess/SceneRenderTargets.h] [Line:640]

No one else has reported this, and i don’t get this error either, not even on my potato labtop machine which can barely run ue4. Any suggestions to any of the above would be highly appreciated

After debugging, I’ve come out. I used LoadClass to define a static member during construction of static members, This not working without editor, I’ve fixed this error by removing it. Thanks to all!!