Packaged Dedicated Server Crashes On Launch

I successfully packaged the dedicated server for my project, but when I launch it, it instantly crashes with the error “The thread tried to read from or write to a virtual address for which it does not have the appropriate access.”

I’m not sure what is causing this or how to go about debugging this particular problem.

Program.Main: ERROR: AutomationTool terminated with exception: System.IO.FileNotFoundException: Could not find file ‘C:\Users[redacted]\AppData\Local\Temp\C+UnrealEngine+UnrealEngine\Logs\Server.log’.

I removed my name from it, but that is the error I am getting whenever I run Frontend with any build configuration with launch set up to “launch as dedicated server”. I’ve tried changing that and it doesn’t change the error, but with Frontend, I can at least see this crash error.

This error is actually occurring even when I try to build the EXE through Frontend.

Well, this is awkward. If you happen to come across this question and you have a System.IO.FileNotFoundException, try to launch your server with debugging and pay attention to the callstack. This was all caused by one plugin that wasn’t cooperate with packaging.