Package for Oculus Rift problems

I’ve been creating a simple environment for use with the Oculus Rift using UE4.13.0. Within the editor, things seem fine. Previewing to VR also seems fine and I can play as expected with the connected rift. However, when I package for Windows 64 (or 32), launching the package just plays the game full screen: when I put on the rift, all I see is black in the rift (the screen stays as full screen game mode).

I even tried a brand new project just with a cube and a light. Again, I can preview in VR mode just fine, but creating the package doesn’t work on the rift.

I am clearly missing a simple step here, but several Google searches have been fruitless.

Any ideas?

We are fortunate enough to also have the Vive, and this seems to work fine with the deployed package. Maybe UE4 doesn’t yet support the Rift CV1?

It definitely supports CV1, though I don’t have any more information that can help you. My Oculus is unplugged currently been developing on the Vive since I can test motion controllers + gamepad through there. I know it was working previously though.

Hey, I had the same issue, and this worked for me with 4.13 in a packaged project (not in standalone game out of the editor):

hope this helps

Very strange. I am on the verge of giving up with the CV1. I am sure it is something I am doing wrong, but the fact that it works ‘straight-off-the-bat’ with the Vive raises concerns.

Try starting the game up with a “-vr” command line option. There is also a .ini setting you can set to go straight to VR.

I’ll give this a try when I next have the CV1 connected. I am now having issues with packaged projects on the Vive - I’ll start a new thread on that one though :wink: