Opening new levels

Hello again,

I’ve been having issues for a while opening new levels (restarting) with mobile. When in the level blueprint I use the open level node, it works on mobile previewer and on pc, but on the device the default map is loaded.

I assume this has to do with packaging, but I would gather that it would be included when deploying to a mobile device? I’m not sure though, any advice would be helpful.

HI Talaricoan,

Have you tried following the steps for packaging on the Epic Wiki: Hello Android.

If you have done this let me know and I’ll see if I can dig into this a little further to help you out.



Hey Tim, thanks for responding.

I just went through that link you sent me, and yes I have done that already. I did change the server map default just in case, but other than that, it is the same.

I did a few test runs that produced some interesting results. On my new game screen, I just have a simple button that opens the next map. Tapping on it, it opens that map, but when I move around and try going to the next map, it won’t open but it will fire the print screen.

If I start from that same map instead, as soon as I do enter the volume to open the next map, it will open the new game screen. Which I can continue to the map that it opens, but with the same results when I enter the volume; nothing.

So yeah, I’m not really sure what is going on, haha. Thank you!

Would you be opposed to posting your test map here (doesn’t need the assets or anything)? Or at the very least create a project that you can reproduce the results on for me to test with?

I don’t have a lot of experience with this per se, but I don’t mind taking a look and learning a little to see what I could do to help you!



The map I did testing on has a lot of custom assets, so that wouldn’t really work. I made a new game project to make sure it wasn’t just that single project that was causing such a weird ‘thing’.

Yet it still is, only on the android device itself. Mobile previewer and the standard previewer works as it should.

But basically:

One map has a button that opens another map. That second map has a volume that opens a third map.
When testing on the device, it will open the second map from the first, but as I enter the volume it will open the default map…in this case the first map.
Sometimes it will just keep opening that second map when I enter the volume.

I hope that makes sense…In both projects, I am using the top-down blueprint package, and I am using the StarterMap and Example_Map as my tests, with a simple custom level that has a box inputTouch event.

Thank you so much for your time!


Hey, I think the answer lies somewhere in the Swing Ninja setup. There must be a few more steps than just using the “Open Level” blueprint command. After downloading Swing Ninja project folder from the Marketplace, I just created a new map and saved it into the project folder. I then changed the “Open Level” blueprint commands to point to my new map, but when deploying to my Kindle, it never would open the new map.

However, when I switched the “Open Level” blueprint commands back to opening the Swing Ninja maps, it worked fine on my Kindle. I went through all of the map settings that I could think of and I never got it to work…Wait! I didn’t try making a copy of one of the Swing Ninja maps instead of creating a new map…maybe that would work.

But, really, I’m just frustrated that I don’t understand why the Open Level doesn’t work in the first place. Good luck.

There must be something different for mobile devices then, because it works fine for me on PC. It will open the maps up correctly and will not reset/do whatever it does.

There is one thing I haven’t tested all the way, which is opening a new level via a button. Because on my “new game” screen, you click and then it opens the map up fine on my phone, though not any other maps when I enter the volume.
I’ll test that out now, but yeah there has to be something. I’ll also take another look at the Swing Ninja setup. Thanks for the response!