Download

Open level function not working as intended (VR)

Hi all,
Iv ran into some trouble in the development of my VR game for the Oculus Quest. I had everything working but i was having some issue with a widget actor not opening the correct level upon the user selecting ‘Proceed to the next Level’ button present in the world. So i jumped on here and i read that the levels should be in the root Content folder and not in any sub directories, so i placed them there…It didn’t work. Not only did it not work, it messed up all my other ‘Open Level’ functions that handle the loading of levels in my game. So i moved everything back to its original location in the folder, but that still didn’t fix the issue. My next guess was to edit the widgets them selves by deleting the open level functions and redoing them over again. This worked! However, iv closed my project down and came back to it later to continue working on it and its happened again. When the user presses play on the widget, the level should load as it always have from the moment of implementation. Instead, it cuts to black (as it always does upon loading a new level) and stays there. it doesn’t load the level at all. I tried the solution i found above again and it fixed it once again, but this time, the solution hasn’t fixed it and its doing it every time now. Any suggestions? Would really appreciate a helping hand here.

Thanks guys.