Download

Only 45 or 90 fps

I see only 45 or 90 fps in my scene in VR mode!
Moreover, when the 90 i get some jitter in static meshes, No lags, namely the jitter. This happens in an empty building, empty! it looks really weird
Looks like the objects fall behind on the camera

In window mode(Selected Vieport or others Comp monitor mode) i get 119-120 fps

FPS I measure this way: 1/DeltaTime

Does anyone have these problems?

Not sure why you get jitter, but from the numbers it sounds like you use HTC Vive? If that’s correct, then it’s framelocked to 90fps and will downthrottle to 45fps if it can’t keep up with 90fps. That is as far as i know not UE4 specific.

In order to get closer to what is causing the jitter, you might wanna post your project or a video showing what kind of jitter you have.

Yes, I use HTC Vive.
It looks really strange, I expected to lag at 45 fps, not for 90
Is there anything in UE4 built-in ability to make a video? Or should I use a different program

If you have an NVIDIA graphics card, I’ve had luck with ShadowPlay, although I haven’t tried it for VR.

Your problem is that your framerate is inconsistent. If it dips occasionally to 45, but is mostly at 90, you’ll see jitter.

As it’s been mentioned before, it’ll cut down to 45 frames if your GPU can’t keep up. What’s your GPU btw ? As for the drops, couple of things that may cause it, try disabling post process, bloom, motion blur, lens flares via project settings as well as make sure your screen percentage is around 100.

Also try using Forward Shading as it’s less performance heavy for VR. (You do miss out on some graphics)

Sorry, i was away from my computer some days.
I have GTX 1060 6 gb, i5 5600.

i have mostly at 45, not at 90. And when i get 90 fps i see jitter. I know it looks strange, but true
Maybe I do not right measure 1/DeltaTime ?