Download

Online Subsystem Steam cant work

I set up OnlineSubsystemSteam in accordance with the documentation. But when I run the project on Standalone Game, the project is not connected to the steam.
Can any one help me?

What documentation did you follow?

Did you enable the Steam plugin?
Are you running Steam on your machine when you start your game in standalone mode?
Show us your “DefaultEngine.ini” file?

We need more information in order to help you.

Try running your game with “Launch” I am having the same problem with steam and doing that makes the overlay and steam connect.

I follow this documentation: https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/index.html

I tried to start my game in standalone mode, and I sure I am running steam.

My “DefaultEngine.ini” just like the documentation shows, I copy it to my .ini file.

I follow this documentation: https://docs.unrealengine.com/latest...eam/index.html

I tried to start my game in standalone mode, and I sure I am running steam.

My “DefaultEngine.ini” just like the documentation shows, I copy it to my .ini file.

I try to running my game with “Launch”, but it still doesn’t work.QAQ

Show me your INI file please … or put it on Pastebin or something.

Here is my INI file.

[/Script/EngineSettings.GameMapsSettings]
EditorStartupMap=/Game/Maps/BeginPlayMap.BeginPlayMap
GameDefaultMap=/Game/Maps/BeginPlayMap.BeginPlayMap
GlobalDefaultGameMode=/Game/Blueprint/BeginPlay_GM.BeginPlay_GM_C
TransitionMap=/Game/Maps/LoadingMap.LoadingMap
ServerDefaultMap=/Game/Maps/BeginPlayMap.BeginPlayMap
GameInstanceClass=/Game/Blueprint/DemoGameInstance.DemoGameInstance_C

[/Script/HardwareTargeting.HardwareTargetingSettings]
TargetedHardwareClass=Desktop
AppliedTargetedHardwareClass=Desktop
DefaultGraphicsPerformance=Maximum
AppliedDefaultGraphicsPerformance=Maximum

[/Script/Engine.PhysicsSettings]
DefaultGravityZ=-980.000000
DefaultTerminalVelocity=4000.000000
DefaultFluidFriction=0.300000
SimulateScratchMemorySize=262144
RagdollAggregateThreshold=4
TriangleMeshTriangleMinAreaThreshold=5.000000
bEnableAsyncScene=False
bEnableShapeSharing=False
bEnablePCM=False
bWarnMissingLocks=True
bEnable2DPhysics=False
LockedAxis=Invalid
DefaultDegreesOfFreedom=Full3D
BounceThresholdVelocity=200.000000
FrictionCombineMode=Average
RestitutionCombineMode=Average
MaxAngularVelocity=3600.000000
MaxDepenetrationVelocity=0.000000
ContactOffsetMultiplier=0.010000
MinContactOffset=0.000100
MaxContactOffset=1.000000
bSimulateSkeletalMeshOnDedicatedServer=True
DefaultShapeComplexity=CTF_UseSimpleAndComplex
bDefaultHasComplexCollision=True
bSuppressFaceRemapTable=False
bSupportUVFromHitResults=False
bDisableActiveActors=False
bDisableCCD=False
MaxPhysicsDeltaTime=0.033333
bSubstepping=False
bSubsteppingAsync=False
MaxSubstepDeltaTime=0.016667
MaxSubsteps=6
SyncSceneSmoothingFactor=0.000000
AsyncSceneSmoothingFactor=0.990000
InitialAverageFrameRate=0.016667

[/Script/Engine.GameEngine]
+NetDriverDefinitions=(DefName=“GameNetDriver”,DriverClassName=“OnlineSubsystemSteam.SteamNetDriver”,DriverClassNameFallback=“OnlineSubsystemUtils.IpNetDriver”)

[OnlineSubsystem]
DefaultPlatformService=Steam

[OnlineSubsystemSteam]
bEnabled=true
SteamDevAppId=480

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName=“OnlineSubsystemSteam.SteamNetConnection”

Add the same ID number for SteamAppId … I found that SteamDevAppId actually had no effect for me and had to have both in my config file.

So should I get a SteamAppId? I just want to test my project, where can I get the SteamAppId?

No … you can only get a Steam App Id once you are greenlit … for now you use the demo app id … 480 … this is a game called Spacewar that is available to developers on Steam.

So…why my project can’t link to steam?

It is probably not working because you are using the field SteamDevAppId and not SteamAppId as well. This is what I have on my config file to get it working and I have also ensured the plugins are enabled int he project.

[OnlineSubsystem]
DefaultPlatformService=Steam
PollingIntervalInMs=20

[OnlineSubsystemSteam]
bEnabled=true
SteamDevAppId=480
SteamAppId=480
GameServerQueryPort=27015
bRelaunchInSteam=false
GameVersion=1.0
bVACEnabled=1
bAllowP2PPacketRelay=true
P2PConnectionTimeout=90

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName="/Script/OnlineSubsystemSteam.SteamNetConnection"

I try to copy these to my config file and Launch my project. But it still doesn’t work.
Whether it is because I have modified the built-in version of the steam SDK.

D:\Epic Games\UE_4.15\Engine\Source\ThirdParty\Steamworks
Steamworks.build.cs:
/** Mark the current version of the Steam SDK */
string SteamVersion = “v139”;
Type = ModuleType.External;

I download the steam SDK from Steamworks.

I am using the provided version of the Steam SDK and it works just fine for me. I am sorry but I don’t think I can help you any further, maybe someone else can assist as I have not experienced any of the issues you are experiencing. Good luck.

All right, whatever, very thank you for your help.

I have found the solution. Just enable the plugin in the editor, everything will be working!

I did ask you this in my first post … glad you figured it out.

How do you enable the plugin? I am having the same problem.

Guys i found solution just apply steam subsystem plugin to your projekt