Odd reflection behavior - What options do we have to correct it?



Notice how the reflection on the floor mimics that of the top? (Note the reflection of the light source, which sets atop the table, not under)
There also isn’t any source of light under the table. Further yet, note that the surface only reflects what is within direct view. Anything outside of that is simply not rendered in the reflection.


-confirming no light under the table.

There are plenty of sphere reflection captures to cover the room, too.


-What methods could we try to get around this issue?
-Have you had similar experiences while working with the engine?
-What have you tried in an attempt to counter the issue? What was the result?

– Technical info –
-Win7, 64bit
-UE4 version: 4.0.2
-GPU: AMD Radeon HD 6530 /w Dx11 support, 512mb (Yes, it’s slow though however it works for demo purposes)

-Floor material: Burnished steel (unmodified)
-editor settings:


-Lighting was built in production mode before screenshots were taken.
-All screenshots were taken from the editor.

Hi, you are experiencing a potentially misleading part of how reflections are handled. Let me explain:

To see the spherecubemap reflections, you actually need to rebuild lighting and have some kind of indirect lighting that will get baked. That’s because in UE4 the reflections get tinted by the amount of indirect light. 0 indirect light means 0 reflection cubemaps. Either add an an ambient cubemap or environment color set to something in world properties. You can preview reflections using the view does also. And you can disable screen space reflections under the drop down flags. It’s either under lighting, advanced or post process. You could also try adding a skylight and rebuilding.

Screen space reflections on the other hand always render. This can be confusing when you see only the screen space reflections.

Also, the screen space reflections are not perfect. That case where it reflects the top of the table on the floor is one such case.