Oculus with 4.10 and Windows 10 VR Preview greyed out

Hi All, it’s been awhile since I had my Oculus running with my games, not since using UDK actually. I am struggling to get it working now.

I’m using Windows 10
I have updated my Nvidia driver
PC runtime is V.0.8.0

Downloaded PC SDK V.0.8.0 (however there doesn’t seem to be a way or instructions on how to install this or run any of the samples) If i double click on something it asks what I want to run it with, and I have no idea.

I have tried to

use the alt-enter short cut. (no-go)
I have tried to add a command line to my blue prints with : Stereo On (as someone suggested, no-go).
I have of course made sure the oculus plugins are all on, and restarted, as well as restarting my computer and updating NVIDIA drivers.
My Oculus is on. The HDMI and the USB cable are plugged in, all before I start up UE4.

Is Oculus planning on making it this hard to get their consumer grade product to work correctly, because this is torture every time I have to get this working again after updates, or trying on new computers etc.

I"m wondering though if the SDK needs to be installed in a way that I just don’t see? I don’t see anything to do install it… nor instructions on where that folder should go.

Any help greatly appreciated.

Does the runtime demo scene work? Also what graphics card have you got?

There should be no need to compile the SDK. The SDK is included with the plugin.

I’m not even sure i’m running the right stuff, the project files they supply are pretty confusing, but for instance I try to run OculusWorldDemo (the one that says it’s an application).

I’ve also run the oculus debug thing just now.

both give me the same error. HDM not connected. It is. My oculus is on, i can see my monitor through it (not stereo of course yet).

My HMDI port works fine for my second monitor when i connect that. Wondering what this means, and whether I’m trying to run the right demo files.

If you’ve got the 0.8 runtime installed correctly you should’nt be able to see your desktop though the HMD as they got rid of that and made it Direct Mode only a while back.

Also are you sure your running the right driver? Acording the Oculus Website…

Plus you still did’nt say what GPU you’ve got?

Thanks, yes I updated my NVIDIA driver, I’ll double check to see what version. I’m using a Nvidia GeForce GTX 970M for graphics on a Maingear system

I’m using 364.51 as my driver for Nvidia, updated today

Ah, Laptop.

Yes well it’s a new laptop, this was working with my old crappy laptop previously using UDK. Now I’m using a Maingear machine that is a gaming system, that I use for game development, and is faster than my workstation.

laptops can be more powerful than other computers, it’s racist for them not to support my laptop or something.

but thank you for this link it has my HDMI error listed… and trouble shooting. I could’ve read it more carefully before wise-cracking about Oculus being racist against my laptop.

i’ll take a close look and see what i can get done

I tried what was written on that page. Nothing working so far, have searched over and over, it isn’t just in UE4, the demo gives the same HMD error. Not seeing a reason why it wouldn’t work.