Oculus Touch and World To Meters


I recently tried to port our game from Vive to Oculus w. Touch controllers. The game heavily utilizes WorldToMeters adjustments and when scaling it down, the transform of the motioncontroller components goes whack and they are no longer where they are supposed to be. Tried with 4.12.5 and 4.13p2.

A look at the SteamVR-plugin shows that there is code to handle WorldToMeters, but there is nothing within OVR.

Does anyone have experience with this or should I file a bug-report? Thanks!

I’m running into this same issue with the Oculus Touch controllers in 4.13. Setting the WorldToMeters scale on the map settings works as expected, but if you change the value at run-time the transforms of the motion controllers aren’t scaled correctly. You can easily reproduce the issue in Epic’s default VR template project by adding code to increase and decrease the WorldToMeters scalar when you press a button. However, this appears to be an Editor-only bug, as everything works as expected in a published build.

This is definitely an issue in the editor only. After upgrading our project from 4.11.2 to 4.13.1, I spent about two days trying to figure out what was wrong and then using world to meters and scaling positions etc. But the hands are in the complete wrong location. This only happens on the Oculus Rift. When testing in the VIVE everything is normal but the hand positions and rotations do not match the change in scale on the Oculus.

When you build the game for shipping it is resolved but this is not really a great solution as we have to wait 20-30 mins per build to see if the changes we have made are working within the Rift.

It was previously working correctly in the 4.11.2 build of the Engine.