Download

NVIDIA GameWorks Integration

The last time I tried I used the command line except for cloning the repo, than got stuck at step 6.

AFK at the moment, once back at my workstation, I’ll try doing all in VS cmd.

Just wondering how is running it from the VS command line different from just running it using the icons or any other command line?

Not sure that this will help with what you are encountering but. . . I believe Visual Studio command prompt will set the path and environment variables that may be of help.



PATH=%PATH%;etc. . .
SET KEY=VALUE
SET KEY=VALUE


It is up and running now. All I needed was .net 4.6.2 targeting pack in VS.

@formatc2013 glad to hear it :slight_smile: Thanks for letting me know. . .

@Jerry.Richards

Just wondering if the build process is going ok for you.

My one gets stuck just after it tries to compile the Blast module.

I am getting these errors on packaging.

UATHelper: Packaging (Windows (64-bit)): ********** BUILD COMMAND STARTED **********
UATHelper: Packaging (Windows (64-bit)): Running: F:\UnirealEngine-Blast-PhysX\Engine\Binaries\DotNET\UnrealBuildTool.exe UnrealPak Win64 Development -NoUBTMakefiles -Manifest=F:\UnirealEngine-Blast-PhysX\Engine\Intermediate\Build\Manifest.xml -NoHotReload -log="F:\UnirealEngine-Blast-PhysX\Engine\Programs\AutomationTool\Saved\Logs\UBT-UnrealPak-Win64-Deve
lopment.txt"
UATHelper: Packaging (Windows (64-bit)): Using 'git status' to determine working set for adaptive non-unity build (F:\UnirealEngine-Blast-PhysX).
UATHelper: Packaging (Windows (64-bit)): Waiting for 'git status' command to complete
UATHelper: Packaging (Windows (64-bit)): Terminating git child process due to timeout
UATHelper: Packaging (Windows (64-bit)): Writing manifest to F:\UnirealEngine-Blast-PhysX\Engine\Intermediate\Build\Manifest.xml
UATHelper: Packaging (Windows (64-bit)): Target is up to date
UATHelper: Packaging (Windows (64-bit)): Total execution time: 55.58 seconds
UATHelper: Packaging (Windows (64-bit)): Took 56.0370361s to run UnrealBuildTool.exe, ExitCode=0
UATHelper: Packaging (Windows (64-bit)): Running: F:\UnirealEngine-Blast-PhysX\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game Win64 Development -NoUBTMakefiles -remoteini="F:\Storage\works\Unreal projects\POLYGON_Fantasy_Kingdom_Unreal_Project_4_22\PolygonKingdom" -skipdeploy -Manifest=F:\UnirealEngine-Blast-PhysX\Engine\Intermediate\Build\Manifest.xml
-NoHotReload -log="F:\UnirealEngine-Blast-PhysX\Engine\Programs\AutomationTool\Saved\Logs\UBT-UE4Game-Win64-Development.txt"
UATHelper: Packaging (Windows (64-bit)): Using 'git status' to determine working set for adaptive non-unity build (F:\UnirealEngine-Blast-PhysX).
UATHelper: Packaging (Windows (64-bit)): Writing manifest to F:\UnirealEngine-Blast-PhysX\Engine\Intermediate\Build\Manifest.xml
UATHelper: Packaging (Windows (64-bit)): Building UE4Game...
UATHelper: Packaging (Windows (64-bit)): Using Visual Studio 2019 14.26.28806 toolchain (H:\vs\VC\Tools\MSVC\14.26.28801) and Windows 10.0.18362.0 SDK (C:\Program Files (x86)\Windows Kits\10).
UATHelper: Packaging (Windows (64-bit)): Building 3 actions with 8 processes...
LogSlate: Took 0.047093 seconds to synchronously load lazily loaded font '../../../Engine/Content/Slate/Fonts/DroidSansMono.ttf' (77K)
UATHelper: Packaging (Windows (64-bit)): [1/3] Module.Blast.cpp
UATHelper: Packaging (Windows (64-bit)): F:/UnirealEngine-Blast-PhysX/Engine/Plugins/GameWorks/Blast/Source/Blast/Private/BlastMesh.cpp(66): error C2039: 'bForceRebuildOnCache': is not a member of 'USkeletalMesh'
UATHelper: Packaging (Windows (64-bit)): F:\UnirealEngine-Blast-PhysX\Engine\Source\Runtime\Engine\Public\Rendering/SkeletalMeshRenderData.h(10): note: see declaration of 'USkeletalMesh'
UATHelper: Packaging (Windows (64-bit)): Took 338.898068s to run UnrealBuildTool.exe, ExitCode=6
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool failed. See log for more details. (F:\UnirealEngine-Blast-PhysX\Engine\Programs\AutomationTool\Saved\Logs\UBT-UE4Game-Win64-Development.txt)
UATHelper: Packaging (Windows (64-bit)): AutomationTool exiting with ExitCode=6 (6)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error

And the one in the attachment.

Anyone run into these?

@formatc2013 IIRC, Debug packaging was the only version that worked for me. I did run into the same issue you are seeing. This is from memory and I would have to verify it. If you are planning on releasing from this branch I can invest some time to see if I can resolve the issue(s) but there are no guarantees.

It’s ok for now, I am just experimenting, but please let me know if it’s ready!

@formatc2013 Actually, at the moment I am working on my own editor and game engine. Basically creating a product to compete with 3dsMax/Maya and UE4/5. I am offering my help since this is somewhat fresh on my mind, and it makes use of NVidia codebase (I love NVidia and have used their products for years). I cannot spend too much time on it but if it is something that you will use then I’ll take a quick stab at it. . . but offer no promises. Some of the bugs can take hours to track down.

That sounds like a daunting task. Are you working on it alone?

4.25 evry time crash when groom importing

Hi there, I am trying to create a custom built of Unreal Engine for my Studio and I want Gameworks Plugin to be installed there. I have downloaded Gameworks for ue 4.21 and I see there are plugin folders there containing Gameworks features. If I generate Visual Studio files from there and then rebuild it, will it install??

Anyone can help me on this issue and also I am willing to pay for the job done

Can I install HBAO+ plugin on existing ue 4.25 or 4.26 preview ?

Is it possible to use Flex with the latest version of UE4(4.25.4)?
I compiled Flex and it uses the compiled version of UE4(4.19), I would like to work with Flex in the latest version of UE4.

Is there a way to save the results of flex simulation, for example, in the running state, F8 select the model convert to static mesh, save to the hard disk, I am using UE4.20 + flex, very much in need of such a function, thank you!

If you are happy with just storing the Flex Particle Positions in a simple file than you can create your own function in a Blueprint function library somewhat like this (not sure about what includes are really needed):

Add to .cpp file:

#include “FileManager.h”

void UMyBlueprintFunctionLibrary::SaveObject(FString FileSource, UFlexComponent *FlexComponent) {

FArchive *FileWriter = IFileManager::Get().CreateFileWriter(*FileSource);
FString NewExcerpt;
for (int i = 0; i < FlexComponent->SimPositions.Num(); i++) {
	FVector4 &Vec = FlexComponent->SimPositions[i];
	NewExcerpt += FString::Printf(TEXT("%f %f %f"), Vec.X, Vec.Y, Vec.Z);
	NewExcerpt += LINE_TERMINATOR;
}
FileWriter->Serialize(TCHAR_TO_ANSI(*NewExcerpt), NewExcerpt.Len());
FileWriter->Close();
delete FileWriter;
return;

}

Add to .h file:
#include “FlexComponent.h”
#include “FlexManager.h”

UFUNCTION(BlueprintCallable, Category = "FlexParticleLibrary|Other")
	static void SaveObject(FString FileSource, UFlexComponent *FlexComponent);

Storing the actual deformed mesh seems to be more complicated, that is what I am trying to find out myself right now. For getting vertices of static meshes there seem to be solutions like this and this, which use the vertex buffer in the render data, but when I use them with a static mesh extracted from my FlexComponent I only get the undeformed vertices. I think this probably has sth to do with how Flex handles its rendering, but I haven’t quite understood FlexRender.h yet and am a bit lost tbh. Has anybody some experience on how to export the deformed static mesh which we see in the simulation? I guess the data has to be accessible somewhere, somehow, help would be much appreciated ^^

Does anybody know of a branch that combines nvidia waveworks and vxgi? I just cannot get This one to work. It wont generate the project files.

@NicolasBLuj
https://github.com/0lento/UnrealEngine/tree/4.21-GameWorks+WaveWorks
It has bunch of other GW techs too. I have zero idea on VXGI interaction on the actual water though if that’s what you are after: it might not do anything at all for it, it could break etc, it is not something I’ve tested that branch against (mainly tested that individual techs work on their own).