NVIDIA GameWorks Integration

any body merge cataclysm 4.19 in gameworks 4.19??? 4.19 cata work fine but single only

hi olento can you try again your 4.21 flex branch i think main conflict particle because Niagra particle is new added

The main issue with FleX is just the work amount, I haven’t encountered any showstoppers there, I just simply don’t have time to fix all the issues. Main thing that will keep people busy who will try to port it to 4.21 is the physics changes but you can find plenty of examples of the new physics interface on the code base (this is how I ported Blast to 4.21).

Hi, I’m working on a archviz scene for my portifolio and I really need help
i’m doing a beach scenery restaurant and using waveworks 4.19, but i’m facing a real hard time to capture the shore beach sand and make waves working… what exactly I need to do to make the waves on shore working like the demo gdc scene that comes with this custom build editor? I selected the “WaveWorksShorelineCapture” and tried all three options available: render scene primitives and selecting the static mesh of beach sand, legacy or visible only, nothing works :frowning:

I didn’t find any useful docs or youtube videos that can helping me out on this one, then I gave up and getting in touch here

[SIZE=16px] [SIZE=16px] [SIZE=16px] [SIZE=16px] [SIZE=16px] Hi, uhm, not sure if this is the right place to ask this but i’ll just go ahead.

Right, so, i recently downloaded WaveWorks branch of the NvPhysX fork of Unreal Engine, i followed all the steps, extracted it, ran setup.bat, then ran GenerateProjectFiles.bat then opened UE4.sln in visual studio, built UE4 and then built ShaderCompileWorker, once done i tried debugging it or opening the editor manually from within the downloaded files but it just opens the default project selector that i get when i open ue4 from the epic games launcher, i can’t see any example/sample projects and when i make a new project there’s no sign of waveworks in there at all, any help would be very appreciated. Sorry if the answer is obvious but i’m kinda stuck here, worst part is i feel like the hard part should be over…

Thanks in advance

[SIZE=16px] [SIZE=16px] [SIZE=14px]



The waveworks sample project should be accessible through navigating to your engine directory (the waveworks one you compiled). Check the folders there and open it through the uproject.

Hi Brian,
thanks for repply, I made some progress here

but I can’t capture the shoreline correctly and don’t know why
the render target camera is already positioned on top of the area I need to be captured, it also show the visible elements on render target texture, but it doesn’t render the texture correctly when I hit to capture, aways show blank or very weird shapes… the fun fact is, I migrate the necessary stuff from gdc map to my project, and still having this problems. To make sure is something I did wrong or missed, I opened the island map from gdc project again, and start modifying this map a little on landscape editor, just for take a look if this going to capture the new shoreline terrain edited on landscape, and… yeah, it captured but, not getting the new details I sculped on landscape, also the new captured texture is way too different from the one that comes with the project, and the shoreline waves behavior on the new captured texture didn’t works well with the new details on the landscape.

right now I’m using the texture from gdc and positioned this to my XY location of my map to have the waves on my beach, it’s not perfect like I can capture my own shoreline texture, but its a start anyway… going to use this until someone can give me a better info on whats going on.

still testing, and as you can see the foam is not smooth to the beach sand because this is not my shoreline texture, I hope I can make this working as intended for my project.

any update flex 4.21???

Thanks -

Can report back even a novice with some patience can be successful with 0lentos 4.19 build. My very first exploration into Unreal engine was through compiling his 4.19+++ (indicated as the most stable) fork after seeing Youtube videos of FLEX. I found nothing missing Unreal engine or Gameworks wise from versions 20 and 21 release notes I absolutely had to have. Almost compiled it twice because it was missing pages of errors and a build failure when I came back. Flawless victory and it loaded. wow. Accidentally started it on the box before new graphics card was in and was shocked to realize it will actually run the FLEX demo (poorly) on the integrated chipset.

Still working to fully understand collision but managed to make a few demos of my own very quickly. Never realized the lighting features are so nice. Gameworks is much different than what I expected. I would not have poorly fought through compiling the 2 parts that were wanted much less the rest just to find out if they would behave/interact and chug/perform together. Thanks so much for 0lentos part in helping to bridge a very big gap past the demos without all the frustration. Now if things are not perfect at least we know the putting the time in is worth it. Who knows I might actually help build something someday and contribute! Heres to hoping your future projects go well and you get some help on 21 for those that need it!

TL;DR If your just looking and confused I approve of 0lentos 4.19 Its stable enough, easy to build, and lots of fun to play with!

Here to say thank you to @0lento for his work incorporating GameWorks into the UE4 source. I’m successfully running 4.20 + GameWorks and actually was able to successfully merge another branch in for the work I’m doing.

Keep it up man, can’t wait to check out 4.21 once you get Flex working.

any chance of getting vxgi 1 with gameworks on 4.20? vxgi 2 kinda lacks some functionality compared to previous version so getting it would be cool

I am prbly going to manually add VXGI 1 into 4.20 soon so I will link it. I don’t use git though so I will have to see about that so the DL isnt 10 gigs…

If you are trying yourself you have to change a few things in vxgirendering.cpp where it buffers prevviewmatrices to just viewmatrices and declare a few extra things

Updated 4.21-GameWorks and 4.21-Physics to 4.21.2 and fixed some compilation warnings from Waveworks (doesn’t change any functionality, only suppresses the warnings):

And before you ask again, no news on FleX, by the looks of it we’ll not be having 4.21 version unless someone picks it up and fixes the remaining issues.

Volumetric light?

Same deal, although VL at least does compile but it has a rendering issue. I doubt the fix for this would be big even if one examined the 4.21 renderer changes, would probably be really simple fix for the nvidia itself as they know what they are doing there.


first of all thank you so much @0lento for great job,
plz complete the flex, i realy need it

Hi 0lento thank you for all
Can you help me,i want to put a plugin in your branch 4.21 Gameworks,i put to directory plugin,i regenerate project but i have warnings this direcory public and privat does not exist.And when finish build,editor not open,because of this plugin warnings does not exist.Plugin is same version for 4.21

we will see raytracing and gameworks branch on the future ???