Download

NVIDIA GameWorks Integration

Zip file. I stopped using git since it is complicated like I said. Is the git version better and doesn’t have those problems and missing files?

I can still see the shadow in your second picture, it’s just very low contrast because VXGI contribution is really bright.

Are you using HDR emittance in VXGI (bVxgiStoreEmittanceInHdrFormat in BaseEngine.ini)? I’m asking because we found a bug in the UE integration and it’s fixed in the latest release. That bug was causing indirect illumination to be much darker than it should be, if RGBA8 textures were used to store emittance. So, if you don’t have HDR emittance enabled, your diffuse tracing intensity setting is probably much higher than it should be, in order to compensate for that bug. Try reducing that intensity in the new version and see if shadows look better after that.

Actually no, what I just said is incorrect, it’s the other way around: non-HDR lighting should’ve become darker. Still, your pictures with the new VXGI look way too bright, multibounce shouldn’t affect the result like that.

I realize that the shadow is created by a distance field, so you want to replace the light with an emissive surface and get shadows from VXGI? It’s technically possible to get a more or less correct shadow, we could trace cones toward a specific area light, but that would be expensive and that is not implemented in UE4. Getting VXGI shadows from a regular light is not possible.

Hi, i have the same issue, when i unzip the unblocked file i get this issue : " ! F:\UE4 releases\PHYSX\unblock\UnrealEngine-VXGI.zip: Erreur de somme de contrôle dans F:\UE4 releases\PHYSX\unblock\UnrealEngine-VXGI\UnrealEngine-VXGI\Samples\UserContent\SciFiHallway\Content\Textures\Door_02_M2.uasset. Le fichier est corrompu "
Door_02M2.uasset. seems to be corrupted …

OK, now I really understand what’s happening :slight_smile: UE is just not my area, sorry - I work on VXGI core primarily.

Distance field shadows currently cannot be used during voxelization. So when you have a DF-shadowed and VXGI enabled light, it will be voxelized as if it had no shadows. It should be technically possible to use DF ray tracing during voxelization, but I’m afraid it will be very slow. Maybe a solution to that would be to make UE render a regular shadow map for those lights as well, and use the shadow map for voxelization instead of the DF.

I have had problems with the zip files, I will test it today to see if the same problem occurs for me.

I just found a quick&dirty solution to make lights with DF shadows properly voxelized - we just need to render regular shadow maps for them. We’ll try to get a proper solution in the next update, but here’s what you can do right now.

  1. In Engine/Source/Runtime/Renderer/Private/ShadowRendering.cpp, replace line 3267:

if (ProjectedShadowInfo->bAllocated && !ProjectedShadowInfo->bTranslucentShadow && !ProjectedShadowInfo->bRayTracedDistanceFieldShadow)

with the following:


if (ProjectedShadowInfo->bAllocated && !ProjectedShadowInfo->bTranslucentShadow)

  1. In Engine/Source/Runtime/Renderer/Private/ShadowSetup.cpp, comment out or remove all 4 lines that mention “bRayTracedDistanceFieldShadow” (655, 1664, 2106, 2144).

  2. Build and run UE4.

Yes. With these changes, you’ll get soft distance field shadows and correct VXGI voxelization, therefore correct indirect lighting. Shadows in the voxel representation of the scene will be sharp, but you shouldn’t notice that normally.

VXGI cannot replace shadows from regular lights, and most likely it never will. It can, however, render pretty nice shadows from area lights (emissive objects) if you use more diffuse cones, 16 for example.

If I redownload the github version and just copy/paste the SciFi Hallway content to my compiled location, willt hat work?

Probably. In theory you should get the same code whether you clone it or download the zip file.

I tried to download using github client but I always get fatal error and failed to clone error. I could clone the HairWorks branch via github client since it is not that big while I couldn’t for VXGI because it is over 2GB. I contacted github support a long time ago and he said that Github may fail to clone big files. Now zip files has missing files like I noted. It seems Github isn’t really the best choice for such NVidia big works. I never had problems with SVN. :frowning:

I have had no issues cloning the files from github, I have both the VXGI and HairWorks branches cloned right now. I can also say I am also experiencing warnings when opening the Sci-Fi demo level with a cloned version.

Really? and How did you clone both branches using github client (I don’t know how to sue gitsheel)? Did you clone HairWorks to a location then removed the UnrealEngine repository from client then cloned VXGI to anotehr loaction (which clones UnrealEngine repository with same name but has VXGI files)? Is that the procedure you followed? I read that Github client can’t clone different branches from same repository since every branch has the name of the Repository cloned each time (here UnrealEngine) and I can’t add other bbarnch content to same cloned repository sicne they both have same names. Github client isn’t that good for cloning. I really hope they solve their cloning size limit and branches cloning one day.

Im not using the Windows Git client, I am using TortoiseGit, so I just cloned the repo, then renamed the folder, and cloned again so I have UnrealEngine-HairWorks and UnrealEngine-VXGI

I always use the Git shell in a Windows PowerShell console. The Windows Git client is weak. I’ve heard good things about the Tortoise integration of Git too, some people in the office prefer that because it works pretty much like the Tortoise Subversion integration.

If you prefer a GUI, SourceTree seems pretty nice for using GitHub. I’ve used it to clone multiple versions. Though don’t ask me how to get things to actually sync on the GitHub website itself. Haven’t tried merging different branches with it yet.

So what happened with the Witcher 3? Apparently the developers said HairWorks couldn’t be optimized for AMD. I honestly prefer Nvidia DCC tools. Speaking of which, I can’t find the latest versions, nothing seems to show up on my devsupport account.

Hi, i need some help about merging several gameworks build using zip file.
I have succeed to compile hairworks, I’ like know how to merge others builds ??
Thanks.

@Mike I cloned VXGI branch via Github but the samples fodler didin’t appear now. Really weird. Anyway, like what GalaxyMan2015 said, it seems even Git version has the same problems.

It seems even Hairworks is having same problem when I open Manajaldon level, I get this error:

Btw, for HairWorks I noticed that when AA is set to epic the hair strands flicker very much are discontinued dots when they move. When I set AA to low, they are a little betetr and even more hair strands become visible. You advised to disable AA. To disable AA, from what I understood,we need to turn it off from a post process volume like here: 1ef3d178696842fe4642928aede7e7d930e69037.jpeg

but the samples in HairWorks branch have no post process volumes to disable AA from them. So the only option is to set AA to low via setings which doesn’t solve the flickering problems once and for all. Is there a way to totally disable AA for those samples?

I also noticed, there are the human heads samples like in the 1.1 viewer but they don’t have their don’t have their own levels like Manajalodon and Mite. Putting them in a default level doesn’t bring the optimal lighting conditions for the heads and they are almost totally dark, so I have to test them in the Mnajaladon or Mite Levels. It seems each ahirworks sample needs a specific lighting condition to look alright.

I noticed in HairWorksDemo\Content\HairWorks some videos. Are they suppsoed to play in the editor in some tutorial section or what? Also the furspecular and and furwithlights shows that HairWorks can work in such situations while you said there were problems with specular and lighting conditions for UE4 integration. Was that solved with the latest build? Thanks ! :slight_smile:

Hi,

I’ll investigate the problem with the error messages. It seems that they might be inconsequential, given that you are running all of the samples. Are you actually able to see the Manjalodon? He’s the mean-looking animal with fur.

Regarding AA, I’m afraid we’ll have to live with this problem for a little while. The choice was to either push this first pass integration of HairWorks out onto Github now, or wait until we resolved all of these issues before pushing it out. Despite clear indications that this is a WIP, not a production feature yet, I think it was worth distributing it as it is. I’ll ask the team if there is a way to disable the AA completely.

Regarding the human heads, the assets are there and you should be able to put them in individual levels, as far as I know. We decided to go with a single map instead of multiple maps, but we can add more as time goes on. Feel free to experiment with the assets and set up your own level. Ultimately it doesn’t seem right that each HW asset should need its own lighting, the goal should be to have multiple assets looking great in a scene with a single light setup.

I thought I had deleted all the videos from the Content section, perhaps I missed some. They were for internal use while doing the integration.

Thanks,
Mike