nVidia driver freezes when FRAPS is running in background

Hello,

Minimizing the engine will freeze the nVidia driver.

Sometimes it’s immediately, sometimes it’s after 1 minute, sometimes it’s when I’m trying to re-display the UI. Then the refresh of my screen totally stops. However Windows continue running correctly as I can still hear my music, or even continue discussing via Skype. I’m forced to my computer has I don’t have any other solutions.

I think it’s the Slate UI that totally breaks my nVidia drivers (as I get the freeze even with the unreal engine launcher), I was able to get this problem on two different computer running two different nVidia GPU and different drivers.

Additional notes : My computers run perfectly fine any other softwares and games, only UE4 freeze my drivers like this. I met this during the beta (on multiple versions, like #1945001) and with the official release (#2027741).


My two computer configuration :

  • [Laptop]

  • CPU : i7 2630QM (Hyper-treading @ 2/2,9 GHz)

  • RAM : 16gb (4 * 4gb)

  • GPU : GTX 460M (Resolution : 1920x1080)

  • OS : Windows 7 x64

  • [Desktop]

  • CPU : i7 860 (Quad Core Hyper-treading @anonymous_user_22cdc7a4,80GHz).

  • RAM : 16gb

  • GPU : GTX 660 (2 Screens, each at resolution : 1920x1080)

  • OS : Windows 7 x64

  • SSD for the OS + Regular HDD

Drivers tested : 320.49 WHQL, 331.65 , 335.23 WHQL

Hi ,

After the update are you still having this issue? if so can you send me the log file of the crash so we can have a look at what might be going on?

Thank you!

Hello,

Yes, after the update (build 4.0.2 - 2034640) I’m still getting the freeze. On my computer with the 660 GTX with drivers 335.23 WHQL.

My repro/test case was :

  • Launching the editor
  • Opening the mobile project (available in the markerplace)
  • Enabling real-time in the main viewport
  • Minimizing the main window of the Editor to the taskbar
  • Waiting 2/3 minutes by doing something else (like browsing some websites)
  • Trying to maximize the Editor from the taskbar

The freeze occurs right after I click on the Editor in my taskbar, the window don’t even shows up.

Unfortunately there is no log file. Since I’m forced to my computer, there is no up to date log file written on my disk. The ones available mention a correct exit of the engine/editor, which is not the case since I’m rebooting the computer.

Hi ,

We’ve used 4xx and 6xx series cards at Epic for a while now without encountering this before. There are other users on GTX 660s who haven’t reported this yet, either. You’ve determined it’s not driver specific. The same error on two systems makes a strong case your hardware is functioning properly, too.

This leads me to believe it could be valuable to investigate possible interactions with your computing environment that UE4 might be problematic with. Here are some starting thoughts to help you troubleshoot:

  • Are there any Windows settings that you like to set differently than OS defaults? Examples: UI layout, font scaling, registry changes, etc.
  • Do you download all Windows updates?
  • Do you ever change your video card settings from factory defaults?
  • Do you use any 3rd party programs to monitor or optimize your system hardware?
  • What background programs and processes do you run? You might try out the Clean Boot troubleshooting process to see if it works around the fault that’s causing the driver crash How to perform a clean boot in Windows - Microsoft Support
  • Is there any hardware that you use on both your laptop and the desktop? Can you unplug it and/or uninstall drivers for it to see if that makes a difference?

I guess another avenue to pursue is if your interaction with the editor repeatedly encounters this fault, or has gotten your Editor configuration into a state where you continue to encounter it every time you launch.

The Mobile project you downloaded should be in your Documents\Unreal Projects folder (unless you placed it in another location). Inside there should be a Saved folder and a Config subfolder. You can delete this Config folder and try your repro case above. Try to stick to the case steps as cleanly as you can and see if that makes a difference.

Thanks, and let us know if you figure out the problem or make any steps forward with it.

[Edit: Just since I don’t see it mentioned, uninstalling all Nvidia applications and drivers, rebooting, then reinstalling the latest WHQL driver might be worth a shot, too.]

Hi all.

Configuration some as above except
intel i5 quad core, 8gb ram and 660 Ti.

Previous build 4.0.1 run fine except compiling bugs.
After 4.0.2 update, my computer completely freezes in first 2 minutes UEeditor run.

I had a similar situation at some games like eve, bf4… But now they runs fine.

Hello, thanks for you answer ! :slight_smile:
Just to be clear : during my tests I re-installed the drivers properly, not on top of each other to avoid any problems related to that.

So, I followed some of your suggestions and I found the problem. Well, at least the source. I don’t know exactly which fault it is, but when Fraps is running in the background (and when I enabled the option to display my FPS in the corner), the freeze happen as I explained it before. Without Fraps running, no driver freeze at all.

I guess the way Fraps hook into the Direct3D render makes some strong incompatibility. Especially when the window is restored.

I know there is a warning when you are running the editor, but Fraps was working fine most of the time. Sorry to have wasted your time with this issue, it’s my fault since there is a warning already displayed. It was working fine so I didn’t thought about it sooner.

Looks like I will have to find an other tool. :cry:

VIDEO http://youtu.be/4pP9fOozw-k

I’m getting the same editor freeze (nothing else freezes) while using Camtasia. I didn’t get it before today though (I did actually a couple of times but way less frequently, enough that I could get stuff done) … I updated Camtasia to 8.3 but the issue still occurs, and checked my nvidia driver is current (maybe i could roll back). The screen will black flash and then the editor will be mostly or totally . Camtasia continues to record (and I swear a lot).

I’m recording with a new USB condenser mic, but I don’t see how that could affect the display … it works fine.

I don’t have real-time viewport enabled. I have sized the editor to 1600x900 floating window.

I can close UE4 without rebooting.

I’m working on a laptop with a second monitor connected by VGA.

Thanks for the report! It might be worth creating a new thread based on the problems with Camtasia. Your issue may receive more visibility as a separate problem (in case it turns out to be).