Download

Not another overlapping UV thread

Hi guys,
do you have any idea why do I get the overlapping UV error message even if the lightmap UVs are perfect, made first in max and then with built in unwrapper?
Cheers

What do the UV’s for the lightmap look like within UE4 (from withing the Static Mesh Editor)?

If your mesh has enough polygons + the automated UV unwrapper isn’t set to the right ‘min lightmap resolution’, then you will get UV islands that are smaller than 1 lightmap pixel, which causes the editor to throw the ‘lightmaps are overlapping’ issue.
to fix this, go in to the alt-0 viewmode and check that the resolution for your mesh is large enough for the lightmap. you need at least 3 pixels around each island for the lightmap padding to work. then, go in to the build options and set the ‘min lightmap resolution’ to the right size and rebuild.

I second that :wink:

Plus, sometimes in max i have the same problem even if my UVs are perfect…Solution: before exporting i make a ‘Turn to poly’ and put 3 at the ‘Limit Polygon Size’ and voilà… :wink: