Download

Normal Maps, Compression and Usage in 4.7.5

Hello,

I’ve a question about a change within the 4.7.5. update. Since then, all my normal maps are converted to a reddish version, though the compression is still the same as before, named BC5 for TC Normalmaps.

In 4.7.4 the maps still have there bluish look as most normal maps normally do, though they are compressed in BC5 as well, and BC5 is getting rid of the blue and alpha channels to get smaller files as far as I know and described here. I use PNG, JPG and PSD formats.

So far it seems to be a cosmetique issue only on the very first look. But since 4.7.5 UE4 seems to take the R and B channel only wich leads in fact to different results, e.g. vertical lines are nearly gone. See examples attached below, one from 4.7.4 and one from 4.7.5, You can see the different displayed normal maps in the material window and the settings. Both are set to Samplyer Type “Normal”, and both textures are compressed as TC Normal as well in Texture Group “WorldNormalMap”. That is what UE4 does automatically when a normal map is added to the content. And the texture view already shows the missing vertical lines, or better rubs them out.

If this was only a screenview thing I would understand it. But now I have to go through all materials, following this QuickTip wich means to add a multiply and an add node on every normal map I used so far, while UE 4.7.5 won’t load normal maps in the usual way any more. In other words, I can’t use the BC5 because of this issue.

So what went wrong? Is this a new feature wich I don’t get, is there an issue with the local 4.5.7. installation, or how is it meant to use now? Can anybody confirm this issue or is it me only? Wich is the correct workpath now using normal maps?

Thank you for your help.

You should probably post this on Answerhub as well, sounds like it could be a bug.

Thanks, I’ll give it a try.

No bug, I had to switch off “Use DXT5 Normal Maps” in Project Settings. Now it works as before.

Thanks for following up for those who may run into the same issue. =)