Download

Normal Map messed up by UV (channel 0) - leaving uv0 empty helps... why?

Hello!
It seems to be a well known issue that the UVs of channel zero are messing up the normal map in UE. I experimented a little bit and I found out, that the best result is a empty UV channel 0, prevents unreal from taking uv seems into account.

At least in the current project I don’t care about the UV channel 0 since i am baking everything and I can leave it like that.

But is there a way to tell unreal not to use the uv seems on import for the normals? I tried every setting on import but so far the only thing helped was keeping uv0 empty…

Cheers
Felix

UV channel 0 is for texture UVs, so I have surmised that something is going wrong with UE’s use of texture UVs to generate lightmap UVs. When importing, I haven’t seen any settings for telling UE to not use seams. But there is a setting or two that might work to reduce or get rid of the issue. Convert to Scene and the Import Normals and Tangents are two of the settings that could change it. Yet it’s not only changing those that needs doing. The rhetoric around the forum is UE generates lightmaps per mesh, and that’s what ‘causes’ the seams. However, why would it result in seams on certain areas while other areas with multiple meshes don’t get seams. I think you’re right that it is a problem with normals, but it’s also a discrepancy with tangents. Not saying this is it, but it’s almost like the engine is trying to interpolate between one mesh and an adjacent one, yet doesn’t finish it correctly. On meshes with flat base color materials, why would it occur then? It’s the processing of light data across changing tangents / normals. No one has the best solution to it so far that I’ve seen, though sometimes I’ve noticed that the suggestion to not use modular meshes or to create the building with one whole mesh can work. However, I’ve seen it where those suggestions also do not work, according to the user who was asking for help with removing seams.

I’d say do a bit more research about UE and perhaps a different engine or rendering program that successfully converts models to the scene without seams occurring in the lighting result. I’m going to do the same, though I’m mainly trying to get dynamic-only lighting to correctly work and have appropriate results so I need to yet again go on a diverging path from it because I think static and dynamic lighting are similar in some of the issues.