Download

Noob question: Shadow artifacts on imported fbx?

Hi,

I’m getting weird dark artifacts on meshes I import from C4D. Highpoly as well as lowpoly.

First I thought it’s the normals, tried all options here: import normals, import normals with tangents, and compute normals.

Nothing helps. I now think it’s the shadows? Uniform sky lights are good, the artifacts appear once a directional light is used. Tried overwriting the light map res for that object and played with the shadow setting of that light, but can’t get rid of those dark artifacts. UVs are good.

Anyone here who could point me towards the solution? Cheers!

Disable raytraced shadows

1 Like

Thank you, that did the trick.
Would love to keep raytraced shadows though, as they seem to have a higher quality. Any chance to get rid of those shadow artifacts without sacrificing?

It’s an issue with Nanite. It doesn’t properly support raytraced shadows at the moment, it traces against the nanite proxy mesh which results in self-shadowing artifacts.

Meaning one way to avoid it would be to just not use Nanite.

I assume at some point this will be fixed but personally I find virtual shadow maps provide comparable quality to raytraced shadows, that is what I would recommend you use instead.

Highly appreciate your time writing this in-depth answer.
Thank you, this was very helpful.

you can also fix it by changing the Proxy Reduction Percentage right under the nanite button in the mesh settings. It’s highly dependent on your mesh though, on some things 80% works on others 5% barely helps