Download

Non-unity builds working in 4.9.1?

I’ve updated to UE4 4.9.1, and we have turned off Unity builds in order to try and identify the source of an otherwise incomprehensible compiler error we are seeing. When we do this however, we see other build errors that are unrelated and seem as though they are inherent in the codebase as retrieved from GitHub. For instance:

>>
\Engine\Plugins\Editor\PluginCreator\Source\PluginCreator\Private\UI\SPluginCreatorTabContent.cpp(78): error C2653: ‘FPluginCreatorStyle’ : is not a class or namespace name
\Engine\Plugins\Editor\PluginCreator\Source\PluginCreator\Private\UI\SPluginCreatorTabContent.cpp(78): error C2228: left of ‘.GetBrush’ must have class/struct/union
type is ‘unknown-type’
\Engine\Plugins\Editor\PluginCreator\Source\PluginCreator\Private\UI\SPluginCreatorTabContent.cpp(78): error C2660: ‘SPluginCreatorTabContent::GetTemplateDescriptionWidget’ : function does not take 1 arguments
\Engine\Plugins\Editor\PluginCreator\Source\PluginCreator\Private\UI\SPluginCreatorTabContent.cpp(78): error C3861: ‘Get’: identifier not found
\Engine\Plugins\Editor\PluginCreator\Source\PluginCreator\Private\UI\SPluginCreatorTabContent.cpp(89): error C2653: ‘FPluginCreatorStyle’ : is not a class or namespace name
\Engine\Plugins\Editor\PluginCreator\Source\PluginCreator\Private\UI\SPluginCreatorTabContent.cpp(89): error C2228: left of ‘.GetFontStyle’ must have class/struct/union
<<

Are Non-Unity builds for sure working in 4.9.1?