"No compiler was found." VS 2017, UE 4.16

I’m trying to use UE4 on a new system (I never had any issues on my laptop). I installed VS 2017, and then used it to compile the engine from source. When I try to create a project, I get a message telling me: “No compiler was found. In order to use a C++ template, you must install Visual Studio 2017.” This is pretty annoying, since I used VS 2017 in order to compile the engine in the first place.
I have tried uninstalling VS 2017, and installing it again from the button provided next to the error message. I have also tried installing the engine using the Epic Games Launcher, which gives me the same error. I’ve checked which packages should be installed with VS 2017 for UE4, and installed a load of other ones besides.
None of these worked, and I’ve spent a lot of time trying to get UE4 working, so I’d greatly appreciate some help. Thanks :slight_smile:

Edit: the engine version is actually 4.16.1

I’ve finally solved the issue, so hopefully this will help someone else!
I installed VS 2017 to Program Files, not Program Files (x86). This was what caused the issue, and it can be fixed by reinstalling Visual Studio to Program Files (x86).

Edit: Symlinks have worked for me before, and they allow me to make C++ projects in UE4, but after moving Visual Studio it gives me errors when I try to make a class.

thanks man this helped! cast visual studio 2017 in the Program Files folder (x86) and earned)