Download

No Collision! No Collision! (but seriously)

Sorry, couldn’t resist. I’m working with photogrammetry-based meshes to build an extensive set, have never encountered this issue until now. Regardless of settings, I can’t navigate between adjoining meshes comprising tunnel parts. I typically import with collision enabled, I enable Collision under Show in the viewer, for convex shapes I might open the static mesh editor and set Collision Complexity to Use Complex Collision as Simple, what it turn purple with Complex Collision enabled under Collision, Save, viola. None of that now works. I went hunting and found some things I don’t understand, like why in the Static Mesh Editor the LOD 0 Materials feature a Enable Collision checkbox. These defaulted to Enabled, believe this relates to having enabled collision on import, not sure, but with Complex Collision checked the collision object is turquoise, disabling the Material’s Enable Collision checkbox made that return to just seeing the textured mesh (have attached one image for that situation, thanks for clarifying).

I also tried in the Content Browser> Asset Actions> Bulk Edit via the Property Matrix… also attached a snip for that, nada. I then tried reimporting the mesh, no enabling collision to begin with, still locked out from moving through this tunnel in Play. I’m out of ideas (I think). Note, it’s not that I don’t want collision, I do, just resorting to desperate measures to overcome whatever is causing the blocking. Oh yeah, also tried setting each mesh to No Collision (see attached), no to politicize my lament ;^) Thanks for a tip.

Benjy