New Import Into Level Feature bugged? - Help with Switching from Dynamic to Static


For some reason when I use the new feature to import a full scene fbx file from maya the shadows are not working as expected. Shadows are not getting baked into my light maps. The only way to get shadows to show from the directional light is to enable Far Shadow on each object. My directional light and sky light are set to Stationary. All objects have been set to static as well as in the blueprint. (unless I am doing that part wrong, never used blueprints before)

How can I make sure the objects are truly static and contribute shadows into the light maps?

This is a very very large indoor level if that helps.

Please help!

Thank you.